Isolation issues with A64 case?

Started by kuleszdl, July 19, 2020, 06:59:14 AM

Previous topic - Next topic



I have installed the A64 case in the board. When I mount the upper part and tighten the screw, the board does not start. Without the hat or with the hat but the screw only being lose, everything works.

I tried isolating the part around the microUSB connector but no success so far.

Is this a known issue? If yes, which is the part that is most likely to cause the interference?

Thank you!

Edit: I found out that the issue appeared only when the LAN cable was connected as well. Looks like my USB cable was faulty, as it also happened when moving the cable while connected. Interestingly, the voltage stayed at 5V but the amps dropped to zero. Finally, I tried another cable and PSU -  no issues here with closed case. Very strange though...


Glad you solved it - power supply is often the culprit of the issues with stability or boot. When using the case - make sure that no metallic parts of the case are touching the PCB or the components - this might cause short circuits.
Technical support and documentation manager at Olimex


Yes, but wouldn't a short circuit result in the voltage dropping to zero?

The effect I still don't understand is why with the case closed, network + "faulty" power cable does not work while it works with the open case.

Also, there were no isolating washers included with the case. The spacers (between the case and board) are metallic, so I wonder if this could cause some issues? Afair I had similar issues with the Lime2 case a few years ago and solved them by installing such washers.


Unfortunately, I have to reopen this thread.

The overpriced premium cable (>5 Euros) arrived today. But I still have the same issue that the device does not power on with the case cover on. Also, I noticed that the "good" PSU also switches off the board after about 2-3 hours of operation and does not power on for a while afterwards.

I will try to put as much insulation tape as I can around the case and test with a second unit (64-OLinuXino and case) as well.


It can be related to over-heating. When there is no case the air flow would naturally be better.

Also are you using one of these images: ?

Edit: What does it mean "overpriced premium cable (>5 Euros)", what is this cable and where it is located in the hardware setup? While the cable matters, it is more important to have powerful power supply.
Technical support and documentation manager at Olimex


Thank you! And no, I am using Debian stable but this should not matter as the device does not even turn on with the case closed.

Regarding the cable I meant the power cable. In my case I know upgraded to a high quality cable from Delock which is USB A -> 5,5mm x 2,1mm round. As power supply, I use also something that should be definitely capable of handling this little load (Anker Power Port Speed 5).

I don't see either the cable nor the power supply to cause this because it is sufficient to just close the case for the unit to not power on anymore. I will experiment with the isolation tape and report back.


I found a workaround/fix for the issue by applying isolation tape to the top part above the ethernet jack of the upper case part as shown here:

Since I had the trouble only with ethernet connected, this seems logical. Yet I don't know what is going on here electrically since the case is coated and should not cause such issues?


Update: Tried with other board + other case but without the isolate tape => issue did not occur.


Well that is strange. I couldn't replicate it here. Maybe the two front pins under the Ethernet connector touch the metallic box - check if they are not too long or bent forward? The two pins I mean here:

How did you assemble the box? Like this I guess:

Technical support and documentation manager at Olimex


Thank you. And yes, I thought this too at first. However, it looks like there is actually more than enough clearance between the bottom pins and the case and still some clearance between them and the top part of the case.

My observations support the theory that it's rather the two top latches of the ethernet jack that cause this:

With these covered by the isolation tape on the top case part as shown in my previous posting the problem is gone. I also removed the isolation tape on the lower part now to make sure it is really the top part. I tested the device tonight by running it for 13 hours with the isolation tape applied and did not observe any issues so far.


Btw: The affected device was from the "A64-OLinuXino-1G" series. The one not affected was the model "A64-OLinuXino-2Ge8G-IND".

I assume this is due to manufacturing tolerance of the RJ45 jack or its soldering to the board.


This doesn't happen here. There might be something else at stake - can it be related to influence from either the network equipment or the debug medium (HDMI?)? Different polarity, high voltage/potential difference between GNDs?

Can you upload a boot log with the problem and share?

I know you found a workaround but it might affect others, so we usually analyze such reports, thank you for the contribution.
Technical support and documentation manager at Olimex


Sure, I would love to upload a log but there is simply none to share. I run the device completely headless (no HDMI or UART attached), so it's just the USB-Power-Cable and the ethernet jack.

I also tried with a connected USB power meter. In the "isolated" state it goes up to 0.27A and later to 0.4A after plugging it in. In the badly isolated state it either stays at 0.0A or goes up to around 0.02A - 0.04A (depending on the cable used). That's logical since I see at least the red LED go on. But the device itself definitely does not boot (thus no log).

The voltage stays constantly at 4.99V, even in the badly isolated setup.