Welcome, Guest

Author Topic: MSP430 LED Boosterpack does NOT work as advertised!  (Read 4427 times)

pevo

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
MSP430 LED Boosterpack does NOT work as advertised!
« on: September 19, 2012, 04:50:53 AM »
I purchased two of these boards, and both exhibit the same problem.

If any LEDs in column 8 are on, the other LEDs are dimmed so much that they are effectively OFF. If you look at the schematic at the following link, you can see that the net labelled "ROW8" is sinked by a discrete transistor, whereas the other columns are sinked by a 7-channel darlington array. Why a uniform 8-channel array was not chosen is beyond me (cost?). At any rate, I theorize that the transistor has a lower effective resistance than the darlington array when the bases are driven by the recommended 3.3 volts.

If I could return these I would.

tl;dr; DON'T BUY THIS

Photo of my defective-by-design LED matrix:
http://imgur.com/KyIGT

Schematic:
https://www.olimex.com/Products/MSP430/Booster/MSP430-LED8x8-B00STERPACK/resources/MSP430-LED-BOOSTERPACK-schematic.pdf

olimex

  • Administrator
  • Hero Member
  • *****
  • Posts: 812
  • Karma: +22/-3
Re: MSP430 LED Boosterpack does NOT work as advertised!
« Reply #1 on: September 19, 2012, 08:57:43 AM »
Hi
MSP430 LED Boosterpack is not designed to work in static drive mode, all currents are calculated for dynamic mode, so you can download the code from our web site and see by yourself that it works correctly when driven dynamically or check other people projects with this booster pack like this video http://www.youtube.com/watch?v=Vwq0-ocWkYk

Kean

  • Jr. Member
  • **
  • Posts: 91
  • Karma: +3/-0
Re: MSP430 LED Boosterpack does NOT work as advertised!
« Reply #2 on: September 19, 2012, 05:18:57 PM »
@pevo,

Can you post you code ?  It sounds like a timing issue.
The different transistor for ROW8 shouldn't make that much of a difference.

Kean