Olimex A64-OlinuXino-1Ge4GW ethernet problem

Started by asimko, July 03, 2019, 03:43:59 PM

Previous topic - Next topic


I have two new A64 devices, but i have problem with ethernet, which is not working. I tried both official images, with 5.x kernel and also witch 4.x kernel, ethernet is not working. Already u-boot is complaining about ethernet:
Could not get PHY for ethernet@1c30000

I tried to use different dtb files found on internet, tried to raise tx-delay-ps, compiled own mainline u-boot, problem still remains. It is the same on both devices.

Can somebody point me what could be wrong?

Thank you for any answer!


My guess:
A64 multiplexes LCD and Ethernet, so if you conect/use LCD the Ethernet is disabled and vice versa.


As olimex said! Check the state of the PHYRST1 jumper, make sure it is open. If it is closed it keeps the Ethernet in reset. Try without LCD.

Additionally, make sure to run dhclient on the Ethernet interface, maybe try adjusting the Ethernet settings of the board.

The official images have Ethernet working so no point testing with other dts/dtb/images/etc. Each board also passes couple of Ethernet tests, including a throughput test.
Technical support and documentation manager at Olimex


Great, so the whole problem was the jumper. I spent with this 3 days of trying different things, but i would never look at some jumper on the board if you didnt write me to that.

Anyway thank you!