8 GB NAND booting

Started by grizlos, February 11, 2019, 05:29:06 pm

Previous topic - Next topic



I have a new A10 module with 8GB NAND and tried booting Debian from it but had no luck so far. I've followed the guidelines from https://www.olimex.com/forum/index.php?topic=3251.0 (it worked perfectly for the 4 GB board) but end up with the messages:

HELLO! BOOT0 is starting!
boot0 version : 1.5.0
dram size =512
Succeed in opening nand flash.
Succeed in reading Boot1 file head.
The size of Boot1 is 0x00056000.
The file stored in 0X00000000 of block 2 is perfect.
Check is correct.
Ready to disable icache.
Succeed in loading Boot1.
Jump to Boot1.
[       0.181] boot1 version : 1.5.0
[       0.181] pmu type = 3
[       0.183] bat vol = 305
[       0.215] axi:ahb:apb=3:2:2
[       0.215] set dcdc2=1400, clock=1008 successed
[       0.217] key
[       0.229] no key found
[       0.229] flash init start
[       1.531] flash init finish
[       1.533] fs init fail
[       1.533] fs init fail, jump to fel

I have tried creating the partitions manually with different sizes, with nand-part and with fdisk. Nothing works. I tried flashing the official Android image with LiveSuit and that works.

If there's anyone with experience with the 8GB board, please help