Touchpad does not work anymore

Started by binutzu, May 31, 2018, 10:56:59 am

Previous topic - Next topic

binutzu

Hello Support Community,

I have the issue that the touchpad is not working anymore. Some months ago I had an issue with it and solved it by adjusting and reinserting the cable connecting the touchpad with button board (TERES-029-FPC-Touch-Btn). Similar issue was reported before by other users.
https://www.olimex.com/forum/index.php?topic=5950.msg24352#msg24352

A couple of days ago the issue occured after running a high cpu load combined with a full charge of the battery. I suspected that there was some displacement due to the heat. Adjusting the cable helped for few minutes but then the touchpad stopped working again. I had several such attempts with same result. Also trimmed 1mm of ribbon ends.

But now the touchpad does not work at all.
Both touchpad buttons work.

I verified with a multimeter that the ribbon is not broken as well as on board pin to pin connectivity with cable inserted. So I have to exclude this as cause.

How could i tell if the KBD controller is able to see anything from touchpad or test if the touchpad is broken?
Maybe with a modified version of TERES-HID...

Thanks in advance for help.

Regards

olimex

most probably issue is bad cable connection

lambda

I think there is also a software issue with the touchpad - but I have never been able to reproduce it reliably, so didn't report.

Conditions seem to be:
  • using the preinstalled ubuntu system
  • having an external mouse (or maybe any USB device?) attached or maybe just attaching it at some time during booting
  • instead of booting maybe suspend/resume is somehow related

    Whenever this happend for me, so far removing all external USB devices and doing a cold start fixed this for me.

    Rather mysterious that, but since I'm using now debian most of the time, I didn't investigate further.

    HTH,
    Harald

binutzu

Hi,

As i do not make any progress adjusting the cable connection i intend to replace some cables, maybe also the button board and the touchpad (in the spirit of DIY laptop ;-)

Regarding the touchpad i have two challenges:
- touchpad cover: @Olimex: i do not see any replaceable case parts in white in the shop, only black. Is is possible to order white case spare parts?
- is there an (easy) way to replace the touchpad, as it is sticked quite well to the keyboard case part

Regarding debugging: the modified TERES-HID KeyboardMouse.c firmware gives only tpdata[2]=0. The events seem to come on tap or drag but all of tpdata[0..6] is filled only with 0.

Thanks and Regards

binutzu

Just for the update.
The problem was the button board which i replaced with a new one. Old ribbon cables are still used although i ordered new ones as well.

@Olimex: thanks for the fast delivery.

Glad to have a fully working Teres laptop again  :)


unclouded

July 30, 2019, 08:49:02 am #5 Last Edit: July 30, 2019, 12:46:35 pm by unclouded
I had the same problem.  It could be worth testing continuity with a meter.  I found a break in the Vcc line between the two connectors on the PCB3-TOUCH-BTN board.

This schematic was useful in diagnosing the problem:
https://github.com/OLIMEX/DIY-LAPTOP/blob/master/HARDWARE/A64-TERES/TERES-PCB3-TOUCH-BTN/Rev.A/TERES-PCB3-TOUCH-BTN_Rev.A.pdf

..and the bodged repair with some wire wrapping wire:


..and the touchpad now works! :)