Welcome, Guest

Poll

what are all the changes initially want to made with ESP8266 dev module

mode setting
0 (0%)
swapping tx and rx
0 (0%)

Total Members Voted: 0

Author Topic: mod wifi esp8266 dev board  (Read 675 times)

Prasanth

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
mod wifi esp8266 dev board
« on: March 02, 2018, 08:56:08 AM »
Dear all,
    I'm a beginner for using ESP8266 wifi module. while connecting this wifi module with usb serial converter to PC i can't able to communicate with it like when i send "AT" to it i can't get anything back from wifi. Its crystal frequency is 26Mhz and default flash mode.
    When swapping the tx and rx lines then getting the below information from that.
à
 ets Jan  8 2013,rst cause:1, boot mode:(3,6)


 ets Jan  8 2013,rst cause:1, boot mode:(3,6)

load 0x40100000, len 2408, room 16
tail 8
chksum 0xe5
load 0x3ffe8000, len 776, room 0
tail 8
chksum 0x84
load 0x3ffe8310, len 632, room 0
tail 8
chksum 0xd8
csum 0xd8

2nd boot version : 1.6
  SPI Speed      : 40MHz
  SPI Mode       : QIO
  SPI Flash Size & Map: 16Mbit(512KB+512KB)
jump to run user1 @ 1000

rf cal sector: 507
rf[112] : 00
rf[113] : 00
rf[114] : 01

SDK ver: 2.0.0(656edbf) compiled @ Jul 19 2016 17:58:40
phy ver: 1055, pp ver: 10.2

"ÀjÅì 

I don't now what changes i want to made. Please assist me to work with this module.

Thanks & Regards,
Prasanth.

Lurch

  • Sr. Member
  • ****
  • Posts: 272
  • Karma: +11/-0
Re: mod wifi esp8266 dev board
« Reply #1 on: March 02, 2018, 03:36:39 PM »
The modules are loaded by Olimex with one of their demo programs. It doesn't run the AT stack you want. If you want to work with AT commands, you will have to load the AT image. There are documents and images at Espressif on GitHub to do this.

Prasanth

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: mod wifi esp8266 dev board
« Reply #2 on: March 05, 2018, 07:46:11 AM »
Thanks for your response Lurch.
  Now i can use AT commands but still i have some problem. I set esp8266 with station mode and i can connect it with mobile wifi hotspot but not with router. If i tried to connect with router it gives time out error. I checked all network parameters like static IP, subnet mask and gateway. What else i want to do?
  Same type of problem gets occurs at access point mode also. When i enable an access point mode i can connect my mobile to it but while tried to connect my laptop to esp8266 it don't get connect. I don't know what problem it is. Please assist me to solve this problem.

Thanks & Regards,
Prasanth.

Prasanth

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: mod wifi esp8266 dev board
« Reply #3 on: March 07, 2018, 07:48:13 AM »
  What is the maximum number of wifi access point connection '4' or "10"?
  Because in your AT command set AT+CWSAP_CUR mention 1-10 connection but AT+CWSAP_DEF mentioned 1-4 connection. I can't set more than 4 connections even if i use AT+CWSAP_CUR.
   I need to know what is the max number of connections and if it is 10 what is the procedure to set it?