Welcome, Guest

Author Topic: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H  (Read 929 times)

kskang

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
work history
OS : ubuntu 16.04
1. libusb-1.0.21 install
2. libusb-compat-0.1.5 install
3. libftdi1-1.4 install
4. OpenOCD-0.10.0 install

I executed the following command
sudo openocd -f ./interface/ftdi/olimex-arm-usb-ocd-h.cfg -f ./target/imx6ull-som.cfg

log
Open On-Chip Debugger 0.10.0+dev-00348-g6f700d2 (2018-03-15-16:02)
Licensed under GNU GPL v2
For bug reports, read
   http://openocd.org/doc/doxygen/bugs.html
Warn : Interface already configured, ignoring
adapter speed: 3000 kHz
srst_only separate srst_gates_jtag srst_open_drain connect_deassert_srst
DEPRECATED! use 'adapter_nsrst_delay' not 'jtag_nsrst_delay'
adapter_nsrst_delay: 500
Warn : imx6ull.sdma: nonstandard IR value
Warn : imx6ull.sjc: nonstandard IR value
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 3000 kHz
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: imx6ull.dapA7: IR capture error; saw 0x00 not 0x01
Warn : Bypassing JTAG setup events due to errors
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response
Error: Could not initialize the debug port
Info : Listening on port 3333 for gdb connections

What am I missing?


LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1819
  • Karma: +46/-2
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #1 on: March 15, 2018, 01:56:16 PM »
Probably something in the hardware connections (adapter layout, signals, cables, etc). Does the target board has standard 20-pin JTAG connector? Check these threads in the freescale's forum:

https://community.nxp.com/thread/386943

https://community.nxp.com/thread/323892

https://community.nxp.com/thread/325849

Technical support and documentation manager at Olimex

JohnS

  • Hero Member
  • *****
  • Posts: 1709
  • Karma: +33/-45
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #2 on: March 15, 2018, 03:34:10 PM »
What Lub said - but also you're running it rather fast and that may be an extra problem.

John

kskang

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #3 on: March 16, 2018, 02:40:53 AM »
Looking at the following link, the i.mx6ull board has a 10-pin connector.
I updated uBoot once, but could not update it after.

https://drive.google.com/file/d/1C9JQxeb5LSwuV7NpKZP8eMGOJe-enkb-/view?usp=sharing


LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1819
  • Karma: +46/-2
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #4 on: March 16, 2018, 02:55:10 PM »
How do you connect the ARM-USB-OCD-H to the board? Can you use the picture that you shared and this picture and draw the correspondence as in your connection?
Technical support and documentation manager at Olimex

kskang

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #5 on: March 19, 2018, 02:16:02 AM »
This is a picture of "i.MX6ULL Borad" and "Olimex ARM-USB-OCD-H".
I have connected "Olimex ARM-USB-OCD-H" to my Linux OS PC.

reference :
https://drive.google.com/file/d/1YKnFInG6x6OxtHl-bYkDzB4RqvfA7GGu/view

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1819
  • Karma: +46/-2
Re: U-boot update to EmCraft i.MX6ULL Borad using OLIMEX ARM-USB-OCD-H
« Reply #6 on: March 19, 2018, 02:00:22 PM »
The orientation of the small cable looks weird to me but I can't be sure where the ticks of the connectors are. Check how this cable looks here:

https://drive.google.com/open?id=1GtSOr5o33bciPcrwCNawCBQ4Vy3egNto

https://drive.google.com/open?id=1KQAup_JZ0HkaFIr_qj-ikeVLks1KSGFJ

So double check the hardware connections again. Maybe use a multi-meter tool and set it to short-circuit check mode, disconnect the 10-20 adapter from ARM-USB-OCD-H and insert a pin at the end of the small cable and place one multimeter electrode on the soldering at 10-20 adapter (under the connected 0.05" cable) and the other on the pin that you inserted in the connector at the end of cable. This would help you identify where is pin #1 after the cable.                                               
                                                                                                                 


I assume that you power the target board from another location, if you don't, please power the iMX6ULL board from another source.

Also I saw this guide for the board:

https://www.emcraft.com/som/imx-6ull/reloading-uboot-using-jtag-programmer

Notice that there are visitable links - that contain the needed cfg files, make sure to use the cfg files provided by the manufacturer (they also seem to use Olimex ARM-USB-OCD-H as seen in one of the links here: https://www.emcraft.com/som/imx6ull/mfg-jtag.cfg).

Since EmCraft seems to be familiar with ARM-USB-OCD-H, it might be a good idea to also drop them an e-mail, maybe they would know more about the proper software and hardware setup.

Best regards,
Lub/OLIMEX
« Last Edit: March 19, 2018, 02:24:49 PM by LubOlimex »
Technical support and documentation manager at Olimex