A64 continuously reboots - uboot

Started by erikly01, November 28, 2017, 06:42:04 AM

Previous topic - Next topic


Hi guys, I installed the official Ubuntu image for the A64 [Nov 27, 2017], but the image never boots into the OS.  Instead it continuously reboots with the output below.

What can I do to solve this problem?

HELLO! BOOT0 is starting!------!-!
boot0 commit : 8
boot0 version : 4.0.0
set pll start
set pll end
rtc[0] value = 0x00000000
rtc[1] value = 0x00000000
rtc[2] value = 0x00000000
rtc[3] value = 0x00000000
rtc[4] value = 0x00000000
rtc[5] value = 0x00000000
DRAM driver version: V1.0
DRAM Type = 3 (2:DDR2,3:DDR3,6:LPDDR2,7:LPDDR3)
DRAM clk = 672 MHz
DRAM zq value: 003b3bbb
rsb_send_initseq: rsb clk 400Khz -> 3Mhz
ddr voltage = 1500 mv
DRAM single rank full DQ OK
DRAM size = 1024 MB
DRAM init ok
dram size =1024
card boot number = 0, boot0 copy = 0
card no is 0
sdcard 0 line count 4
[mmc]: mmc driver ver 2015-05-08 20:06
[mmc]: sdc0 spd mode error, 2
[mmc]: Wrong media type 0x00000000
[mmc]: ***Try SD card 0***
[mmc]: HSSDR52/SDR25 4 bit
[mmc]: 50000000 Hz
[mmc]: 30436 MB
[mmc]: ***SD/MMC 0 init OK!!!***
sdcard 0 init ok
The size of uboot is 000f0000.
Succeed in loading uboot from sdmmc flash.
boot0: start load other image
boot0: Loading BL3-1
Loading file 0 at address 0x40000000,size 0x0000b400 success
boot0: Loading scp
Loading file 2 at address 0x00040000,size 0x00019c00 success
set arisc reset to de-assert state
Ready to disable icache.
�9=�    Configuring SPC Controller
NOTICE:  BL3-1: v1.0(debug):0bc348a
NOTICE:  BL3-1: Built : 01:16:30, Jan  4 2017
NOTICE:  BL3-1 commit: 0bc348ab272ad81a4faf128ef38f4724f36fded6

INFO:    BL3-1: Initializing runtime services
INFO:    BL3-1: Preparing for EL3 exit to normal world
INFO:    BL3-1: Next image address = 0x4a000000
INFO:    BL3-1: Next image spsr = 0x1d3

U-Boot 2014.07-4-pine64-gfe9e539 (Jul 05 2017 - 14:41:57) Allwinner Technology

uboot commit : fe9e5397ffbe864e5beb946f596e75b924d34056

rsb: secure monitor exist
[      0.384]pmbus:   ready
[      0.387][ARISC] :arisc initialize
[      0.819][ARISC] :arisc_dvfs_cfg_vf_table: support only one vf_table
[SCP] :sunxi-arisc driver begin startup 2
[SCP] :arisc_para size:1a8
[SCP] :arisc version: [v0.1.76]
[SCP] :sunxi-arisc driver v1.10 is starting
[      0.980][ARISC] :sunxi-arisc driver startup succeeded
[      1.024]PMU: AXP81X
[      1.026]PMU: AXP81X found
bat_vol=902, ratio=100
[      1.033]PMU: dcdc2 1100
[      1.036]PMU: cpux 1008 Mhz,AXI=336 Mhz
PLL6=600 Mhz,AHB1=200 Mhz, APB1=100Mhz AHB2=300Mhz MBus=400Mhz
device_type = 3253, onoff=1
dcdc1_vol = 3300, onoff=1
dcdc2_vol = 1100, onoff=1
dcdc6_vol = 1100, onoff=1
aldo1_vol = 3300, onoff=1
aldo2_vol = 1800, onoff=1
aldo3_vol = 3000, onoff=1
dldo1_vol = 3300, onoff=0
dldo2_vol = 3300, onoff=0
dldo3_vol = 2800, onoff=0
dldo4_vol = 3300, onoff=1
eldo1_vol = 1800, onoff=1
eldo2_vol = 1800, onoff=0
eldo3_vol = 1800, onoff=0
fldo1_vol = 1200, onoff=0
fldo2_vol = 1100, onoff=1
gpio0_vol = 3100, onoff=0
gpio1_vol = 3100, onoff=0
vbus exist
no battery, limit to dc
run key detect
no key found
no uart input
DRAM:  1008 MiB
fdt addr: 0x76eba640
In:    serial
Out:   serial
Err:   serial
gic: sec monitor mode
[      1.877]start
init_clocks: finish init_clocks.
enable power vcc-hdmi-33, ret=0
drv_disp_init finish
fetch script data boot_disp.auto_hpd fail
disp0 device type(4) enable
attched ok, mgr0<-->device1, type=4, mode=10
[      2.476]end
workmode = 0,storage type = 1
[      2.480]MMC:        0
[mmc]: mmc driver ver 2015-06-03 13:50:00
[mmc]: start mmc_calibrate_delay_unit, don't access device...
[mmc]: delay chain cal done, sample: 192(ps)
[mmc]: media type 0x0
[mmc]: Wrong media type 0x0
[mmc]: ************Try SD card 0************
[mmc]: host caps: 0x27
[mmc]: MID 03 PSN f0300d8e
[mmc]: PNM SE32G -- 0x53-45-33-32-47
[mmc]: PRV 8.0
[mmc]: MDT m-6 y-2017
[mmc]: speed mode     : HSSDR52/SDR25
[mmc]: clock          : 50000000 Hz
[mmc]: bus_width      : 4 bit
[mmc]: user capacity  : 30436 MB
[mmc]: ************SD/MMC 0 init OK!!!************
[mmc]: erase_grp_size      : 0x1WrBlk*0x200=0x200 Byte
[mmc]: secure_feature      : 0x0
[mmc]: secure_removal_type : 0x0
[      2.797]sunxi flash init ok
[mmc]: Has init
[      2.870]---drivers/mmc/mmc.c 2733 mmc_init
reading uboot.env
FAT: Misaligned buffer address (76e945e8)
--------fastboot partitions--------
mbr not exist
base bootcmd=run mmcbootcmd
bootcmd set setargs_mmc
key 0
recovery key high 12, low 10
fastboot key high 6, low 4
no misc partition is found
to be run cmd=run mmcbootcmd
update dtb dram start
update dtb dram  end
serial is: 00000000000000000000
Model: a64-olinuxino
no battery exist
[mmc]: Has init
[      3.446]---drivers/mmc/mmc.c 2733 mmc_init
reading bootlogo.bmp
3148922 bytes read in 160 ms (18.8 MiB/s)
bmp file buffer: 0x41000000, bmp_info.buffer: 47400000
fetch script data boot_disp.output_full fail
screen_id =0, screen_width =1920, screen_height =1080
frame buffer address 47400036
[      4.475]inter uboot shell
Hit any key to stop autoboot:  2
[mmc]: Has init
[      7.701]---drivers/mmc/mmc.c 2733 mmc_init
reading uEnv.txt
[mmc]: blkcnt should not be 0
118 bytes read in 5 ms (22.5 KiB/s)
Loading boot environment ...
[mmc]: Has init
[      7.722]---drivers/mmc/mmc.c 2733 mmc_init
reading boot.scr
** Unable to read file boot.scr **
Booting with defaults ...
[mmc]: Has init
[      7.742]---drivers/mmc/mmc.c 2733 mmc_init
reading a64/a64-olinuxino.dtb
67677 bytes read in 8 ms (8.1 MiB/s)
[mmc]: Has init
[      7.798]---drivers/mmc/mmc.c 2733 mmc_init
reading a64/Image
12044224 bytes read in 596 ms (19.3 MiB/s)
[mmc]: Has init
[      8.406]---drivers/mmc/mmc.c 2733 mmc_init
reading initrd.gz
1104262 bytes read in 57 ms (18.5 MiB/s)
Image lacks image_size field, assuming 16MiB
## Flattened Device Tree blob at 45000000
   Booting using the fdt blob at 0x45000000
   reserving fdt memory region: addr=41010000 size=10000
   reserving fdt memory region: addr=41020000 size=800
   reserving fdt memory region: addr=40100000 size=4000
   reserving fdt memory region: addr=40104000 size=1000
   reserving fdt memory region: addr=40105000 size=1000
   reserving fdt memory region: addr=45000000 size=11000
   Loading Ramdisk to 76da5000, end 76eb2986 ... OK
   Loading Device Tree to 44feb000, end 44ffefff ... OK

Starting kernel ...

[mmc]: MMC Device 2 not found
[mmc]: mmc 2 not find, so not exit
INFO:    BL3-1: Next image address = 0x41080000
INFO:    BL3-1: Next image spsr = 0x3c5
HELLO! BOOT0 is starting!------!-!


Power the board from external power source AND remove any USB cable attached to the A64 board. Make sure that you are using the latest release #2: https://www.olimex.com/wiki/images/d/d5/A64-ubuntu_built_preliminary_rel_2.torrent

Let us know how it goes.

Best regards,
Technical support and documentation manager at Olimex


Thanks LubOlimex

>#2: https://www.olimex.com/wiki/images/d/d5/A64-ubuntu_built_preliminary_rel_2.torrent
I'm using the image from the link you posted

>Power the board from external power source
If I attempt to power it from the 5v source alone, it won't boot at all.

>AND remove any USB cable attached to the A64 board
I don't have any USB cables attached to the board, or does that include the micro USB cable needed to boot/power the unit?

So far I have tried 1. the 5v power source, 2. Micro USB power source, 3. both power sources plugged in, but none of worked.



The board requires more than 500mA at certain points during the boot. When it reaches such a point and the supply can't provide the required current (and maintain 5V of voltage) - the board would restart.

It seems like insufficient power supply to me. Unless you have externally powered USB, capable of providing at least 1A or more, then most certainly the board remains under-powered.

I tested today with a standard USB micro cable between a personal computer and the board and it just reaches some point of the boot then resets. It seems that the reboot occurs at the same exact time. The log is available here: https://justpaste.it/1dzp4

Get a better power supply or externally powered USB hub - 5V/2A recommended. The power jack can be found here: https://www.olimex.com/wiki/PWRJACK
Technical support and documentation manager at Olimex


>Get a better power supply or externally powered USB hub - 5V/2A recommended
I've only used 5v/2A power supplies. Please see the images.

What does the blinking red LED next to the power jack (pictured) mean? Could I simply have a faulty board?

Blinking Red LED

Power Adapter Set 1

Power Adapter Set 2

Thanks for you help!


Problem solved. The board was defective.  Validated by purchasing a new board and using the same setup.


Thanks for the update. You are probably aware of the returns and warranty policy detailed here: https://www.olimex.com/wiki/GTC#Warranty - so if you purchased the previous board directly from us drop us an e-mail at support@olimex.com for RMA number, else contact the re-seller (if you haven't already).
Technical support and documentation manager at Olimex