Welcome, Guest

Author Topic: Olimexino Nano GSM Shield Not working  (Read 1047 times)

PreciousRoy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Olimexino Nano GSM Shield Not working
« on: September 26, 2017, 02:49:06 PM »
Hello,

I have a Olimexino Nano GSM Shield and i am having trouble getting it to work. I start it and it just blinks 4 times and stops.

I connected it to my fez cobera3 using this lib witch should work
https://www.nuget.org/packages/Eclo.NetMF.SIM800H/

but i get nothing, so i wanted to just try to open a plane serial connection to it but it is unresponsive. does it not do anything if it is not connected to the cell network? i am asuming it is not connected when i read the faq:
Quote
I powered the module but I'm not sure if it works. How can I determine that it works?
To turn on the unit you would need need to press and hold the PWRKEY for a few seconds. The green LED should turn on and start blinking rapidly. The green LED also indicates the status of the communication with the GSM network – after the initial few seconds it begins to blink at a much slower pace – this means that the communication with the GSM network is ok; alternatively if the LED stops blinking – there is a problem with the network (most likely improper network settings).

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Karma: +46/-2
Re: Olimexino Nano GSM Shield Not working
« Reply #1 on: September 26, 2017, 03:54:49 PM »
Did you upload proper UART bridge code to your board? Does your board have two serial (UART) interfaces? One should be used for incoming data, the other for outgoing data...

If you are in doubt, make sure to first test with OLIMEXINO-NANO. The evaluation code for Arduino that we provide was meant for OLIMEXINO-NANO + OLIMEXINO-NANO-GSM (+ OLIMEXINO-NANO-BAT) setup.
Technical support and documentation manager at Olimex

PreciousRoy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Olimexino Nano GSM Shield Not working
« Reply #2 on: September 27, 2017, 08:35:24 AM »
it will take a while till i get a  OLIMEXINO-NANO.... but i was just wondering. if i just give power to the module it should be able to connect to the cell network right?

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Karma: +46/-2
Re: Olimexino Nano GSM Shield Not working
« Reply #3 on: September 27, 2017, 10:34:56 AM »
Yes. I've tested it without any other boards attached to it. It is possible to power the whole board only via VBAT2 line (it is accessible at either pin #1 of the 4-pin 0.1" header at the bottom of the board - the bottom side is the one with the SIM holder - or, alternatively, at pin #6 of connector CON1). Provide 4.2V there or connect a fully charged Li-Po battery.

Also connect serial <-> UART cable if you want to receive data from the board to your computer. You'd need to start a UART terminal software.

Remember to insert a SIM card that is not protected by PIN number (use another GSM device to remove the PIN).

Finally, when everything else is ready, to turn on the unit you would need need to press and hold the PWRKEY for a few seconds.
Technical support and documentation manager at Olimex

PreciousRoy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Olimexino Nano GSM Shield Not working
« Reply #4 on: September 27, 2017, 03:16:08 PM »
ok so i put the sim on a phone and i could send and recieve sms massages. and it does not have a password on it.
and it does not want to connect(Led blinks 4 times and stops). i am wodering id the carier does not have the supported frequency :Quad band 850/900/1800/1900MHz these https://www.frequencycheck.com/carriers/cellcom-israel are suposedly supported here.

am i correct in assuming it should work?


LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Karma: +46/-2
Re: Olimexino Nano GSM Shield Not working
« Reply #5 on: September 28, 2017, 08:18:01 AM »
It could be something mechanical - bad contact between the board and the SIM card - if possible test with another card. It can be insufficient network coverage try in another room. Also notice that sometimes it might take some time to register to the network try a few times.

It is a very good idea to have USB <-> Serial cable attached between the GSM board and your personal computer. Then you can send AT commands and test if the module is responsive. You can also use the AT commands to determine what is going on and why it doesn't want to connect.
Technical support and documentation manager at Olimex

PreciousRoy

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Olimexino Nano GSM Shield Not working
« Reply #6 on: September 28, 2017, 11:54:42 AM »
So I connected It to a serial to usb dongle.

I tried RX to TX and vice versa and was unable to communicate, and I tried tx to tx and the same for rx but I am still unable to communicate. What I did notice is that it does not mater how I connect RX or TX the light on the serial converter stays on.

I hope I did not kill the unit... although when holding down the power button the led still blinks.

Your thoughts?


LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Karma: +46/-2
Re: Olimexino Nano GSM Shield Not working
« Reply #7 on: September 29, 2017, 10:21:22 AM »
Well, you are providing only 3.3V to VBAT.... This is not sufficient....The DC voltage should be in the (3.8-4.2)V range. Providing less than 3.8V would lead to unstable behavior and shutdowns. Providing more than 4.2 volts might cause hardware damage.

Also the power supply should be capable of handling fast and high current spikes (up to 2A). This might be problem with certain DC power supplies that have strict short-circuit protection (batteries doesn't have such problem).

If you don't have a DC power supply, you can step-down 5V. Alternatively, you can use Li-Po battery.
Technical support and documentation manager at Olimex