Microchip PIC32 no recording

Started by Cinderella, March 30, 2017, 12:40:39 PM

Previous topic - Next topic


Hi!I'm new here.

I have been using the Microchip PIC32 USB Starter Kit which I found in Kynix, with the MEB (Multimedia Expantion Board 1) for some projects.

One of them is to record audio and analyse it, the problem here is that Microchip released some demos, one of them with the audio feature just for generating audio, but no recording...

I have spent months working on this with no success. I made a Microchip Ticket request, but their answer was another demo from another board with only audio reproduction...

Has anybody here being able to record audio with the MEB board and with a PIC32 USB Starter kit? I'll be grateful if you could answer me.



I am not sure if I can help you, I have never tried the board nor the codec IC.

First of all, this is the board and codec, right?

What part of your code is not working?
Did you tried to check what is happening on the interface between your PIC and Codec? Probably a measurement first with an Ossciloscope would be good to verify if the voltage is there and changes as expected. Maybe some PIN configuration issue in the PIC. Then you could do a measurement with a Saleae (logic analyser) to see if the signals are changeing as expected.
Can you verify that the microphone that use, is needing a bias or not? Not sure how this Codec is working, but maybe this can be turned off or on, or sometimes turned off due to some constraint. So a simple measurement on the analog part of this could also help.