Welcome, Guest

Author Topic: STM32-E407 problems  (Read 2288 times)

murray2

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
STM32-E407 problems
« on: February 07, 2017, 06:48:52 PM »
Hi,

I'm new to all this so please excuse any major stupidity...
I have a number of problems with an STM32-E407 board revision E. I am attempting to connect to a laptop running Ubuntu 16.04
1. I have powered up the boardvia the power jack and the red and green LEDs are lit as expected. However the board is not recognised as a USB device (both USB-OTG#1 and USB-OTG#2)
2. I changed the jumpers and powered up via the USB connectors. Oddly, the board powers up on USB 1 wit the jumpers in 5-6 and on USB 2 with jumpers at 7-8 the other way round to the documentation. Still no reconition by my laptop.
3. I have tried 3 different usb-mini B cables to try and eliminate any cable issues. I have ordered a cable from Olimex to try and eliminate any mini-A/mini-B differences but it will be a while before it arrives
4. As a side issue, the silk-screening seems to be in error on the boot jumpers which are marked B0_1/B0_1 and B1_1/B1_1 instead of B0_1/B0_0 as I expected
5. I have tried to set up the STM32-E407 board option on the Arduino IDE. I set up the additional board manager URLs as https://raw.githubusercontent.com/OLIMEX/Arduino_configurations/master/STM/package_olimex_stm_index.json and  https://github.com/OLIMEX/Arduino_configurations/tree/master/STM. When I attempt install the board I get the following:
Tool stm32-upload is not available for your operating system.
java.lang.RuntimeException: java.lang.Exception: Tool stm32-upload is not available for your operating system.
   at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$1(ContributionManagerUI.java:176)
   at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.Exception: Tool stm32-upload is not available for your operating system.
   at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:86)
   at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$1(ContributionManagerUI.java:173)
   ... 1 more
I had a look at the github content and stm32-upload does seem to be there (for Windows, MAC and Linux) but not recognised.
6. The Pinguino install works, the but the AVR install fails with a message that micronucleus is not available for your operating system.

Sorry to have so many questions.

Best Regards
Murray

JohnS

  • Hero Member
  • *****
  • Posts: 1709
  • Karma: +33/-45
Re: STM32-E407 problems
« Reply #1 on: February 07, 2017, 08:18:15 PM »
I think it's shipped with a test program in the flash (and not with micronucleus, which I suspect is not even available for the board).

(I've only used mine via JTAG.)

Your USB cable may well be OK.

The page at the URL you posted seems to me to mean you would need a tool (such as JTAG) to upload the bootloader before you could use such as stm32-upload (if stm32-upload would work - I don't know).

John
« Last Edit: February 07, 2017, 08:22:25 PM by JohnS »

murray2

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: STM32-E407 problems
« Reply #2 on: February 08, 2017, 05:27:29 PM »
 Thanks John, I resorted to an ARM-USB-TINY-H and OpenOCD and now have a blinking LED so I've got started now. :)

JohnS

  • Hero Member
  • *****
  • Posts: 1709
  • Karma: +33/-45
Re: STM32-E407 problems
« Reply #3 on: February 08, 2017, 09:54:32 PM »
Good to hear.

I think this may be the wrong forum, should perhaps be in https://www.olimex.com/forum/index.php?board=14.0

John