Welcome, Guest

Author Topic: LPC-P1343 flash programming issue over USB issue  (Read 1896 times)

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
LPC-P1343 flash programming issue over USB issue
« on: July 19, 2016, 02:41:46 PM »
Hi All
       My LPC-P1343 board suddenly stops flash programming option, windows didn't recognize it, it says  one of USB port is malfunctioning, what is issue with this board?, can i use your coocox jtag debuger for programming?.
« Last Edit: July 20, 2016, 08:20:17 AM by raman »

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1819
  • Karma: +46/-2
Re: LPC-P1343 flash programming issue over USB issue
« Reply #1 on: July 20, 2016, 08:58:20 AM »
Hey,

Did it work in the beginning?

If it worked in the beginning and stopped at some point without any changes to the hardware setup (cables, USB ports, etc) - then it is probably your code that might have caused it.

Quote
can i use your coocox jtag debuger for programming?.

Yes, you can use ARM-JTAG-COOCOX with LPC-P1343 - LPC1300 are supported by CooCox software and the tools related to CooCox.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: LPC-P1343 flash programming issue over USB issue
« Reply #2 on: July 22, 2016, 09:15:28 AM »
Ok, first i want to program the flash so that, can i use serial FTDI TTL cable for this with LPC ISP program?

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: LPC-P1343 flash programming issue over USB issue
« Reply #3 on: September 12, 2016, 03:40:54 PM »
Hello Lub
            Now i am able to see my controller flash on both windows and Linux, but my board not go to run mode after roving jumper and reset, it always go to program mode and flash appears, USB LED is always light ON, is there any way to resolve it? and do you have experience with this board, on Linux i used mtools to delete and copy my bin/hex files, also which file is correct BIN or HEX used to run, i tried both but no luck.

 Also after writing my hex/bin file and reset my file disappear and then firmware.bin with size of 32KB appears default at all the time, i don't know whether my file written or not?