Welcome, Guest

Author Topic: Damaged symptom or something else ?  (Read 2189 times)


  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
Damaged symptom or something else ?
« on: July 08, 2016, 12:41:14 PM »
I tried a few SD and a few installation methods (official image, debian image for SD and for USB methods), using the USB serial to see what was up.
The official image just loops saying everytime it don't find any kernel available. The debian one, loads the installer, and then to the installation step tell me that there is no storage device in the LIME, despite the micro-SD that powered the installer in the first place being here. Plugging/unplugging it does not do anyhing. Pluging something elses does work ; but it's like that, past the uboot, the microSD slot is not detected anymore.

 I just saw that the screw of the box could cause malfunctions, or the box pressing buttons, I'll try without that.

What do you think could cause that ? I did every precaution I could on the software part ; torrent download, dd, sync before eject 'n all.
« Last Edit: July 08, 2016, 12:43:54 PM by otyugh »


  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
Re: Damaged symptom or something else ?
« Reply #1 on: July 08, 2016, 01:32:18 PM »
Nah, doesn't work either. There is a sample of the official image looping :
resetting ...

U-Boot SPL 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55)
Board: A10-OLinuXino-Lime
DRAM: 512 MiB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
spl: not an uImage at 1600

U-Boot 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55) Allwinner Technology

CPU:   Allwinner A10 (SUN4I)
Board: A10-OLinuXino-Lime
I2C:   ready
DRAM:  512 MiB
In:    serial
Out:   serial
Err:   serial
Net:   emac
Hit any key to stop autoboot:  0
reading uEnv.txt
104 bytes read in 17 ms (5.9 KiB/s)
Loaded environment from uEnv.txt
reading boot.scr
337 bytes read in 16 ms (20.5 KiB/s)
Jumping to boot.scr
## Executing script at 44000000
reading script.bin
54504 bytes read in 38 ms (1.4 MiB/s)
reading uImage
Error reading cluster
** Unable to read file uImage **
## Booting kernel from Legacy Image at 48000000 ...
   Image Name:   Linux-3.4.90+
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4447440 Bytes = 4.2 MiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... OK
   Loading Kernel Image ... data abort
pc : [<5ffa8410>]          lr : [<5ff8d474>]
sp : 5fb66b38  ip : 00000000     fp : 48000040
r10: 5ffb9a80  r9 : 5fb66f0c     r8 : 5fb68ac4
r7 : 00000000  r6 : 00000000     r5 : 0000070f  r4 : 40008000
r3 : 00000000  r2 : 0043dcd0     r1 : 48000040  r0 : 40008000
Flags: Nzcv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...


  • Hero Member
  • *****
  • Posts: 1651
  • Karma: +33/-45
Re: Damaged symptom or something else ?
« Reply #2 on: July 08, 2016, 03:04:17 PM »
Probably poor power.

Might be bad SD card.



  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-0
Re: Damaged symptom or something else ?
« Reply #3 on: July 09, 2016, 01:31:01 AM »
I tried 3 different micro SD cards that did worked on a pi.

The power adapter is 5V, 1v2A. Thought I did power it also from USB at the same time, isn't that supposed to add up ? If not I may look for a more powerful adapter.


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1642
  • Karma: +42/-2
Re: Damaged symptom or something else ?
« Reply #4 on: July 13, 2016, 11:20:06 AM »

I also feel like this might be related to the power supply. If you can test with another power supply, or try to power the board from the mini USB connector or from a Li-Po battery. The power from the supply and the USB does not add up - the board uses one of them - if external power supply is present it is used. If you wish to power the board from the mini USB - remove the external power supply. Yet, some of the USB ports are not powerful enough to power the board that is why powering from the USB is not reliable.

Try booting when the board is outside of any boxes. Try to boot without anything connected to the board. Just apply power. After few moments connect the serial debug cable, keep the rest of the peripherals disconnected. I feel like some peripheral or your USB<->serial cable is interfering with the boot process.

Best regards,
Technical support and documentation manager at Olimex