Welcome, Guest

Author Topic: help with PIC32-PINGUINO-MX220 (newbie)  (Read 3369 times)

Mark2016

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
help with PIC32-PINGUINO-MX220 (newbie)
« on: December 28, 2015, 01:04:29 AM »
Hi all  Hope you all had an excellent XMAS

Ive recently purchased the PIC 32 Pinguino-mmx220 development board and am very keen to get started with this Get started being the operative word however having real problems with the GUI IDE for Linux Ubuntu 12.04

So far Ive read up on numerous sites and have also tried numerous suggestions and instructions to the letter including Wiki documentation which suggests all manor of possible solutions

Ive have left comments on this  in the Pinguino forum with extensive notes regarding this plus links etc and uploads of debug files also stdout files

I have worked with Arduino and pic micro before using both C , basic , assembler ,  and of course the Arduino IDE for atmel devices MPLABX for pic micro , proton basic too


The problem I'm having and again i have  read through some of your other posts is that I cannot get this compiler or Penguino IDE to actually complete a compile to hex , never mind get to the stage of uploading this to the board itself 

I have already set up the UDEV rules as described but as yet haven't plugged the board in Not much point until you can actually produce some hex code

So far Ive tried the package at Github which runs that means the IDE launches I get full use of the IDE in terms of I can select a board I can select 32bit or 16 bit and I can read example files At beats it seems to find all the libraries ( Version 11 IDE ) Python Ide

I can also get to the stage where an attempt to compile is partially working however what I do receive is an exit code 2 reporting as follows

Please see below
Code: [Select]
/usr/bin/../lib/gcc/mips-elf/4.9.2/../../../../mips-elf/bin/ld: cannot find -lgcc
/usr/bin/../lib/gcc/mips-elf/4.9.2/../../../../mips-elf/bin/ld: cannot find -lgcc
collect2: error: ld returned 1 exit status
make: *** [compile] Error 1

Ive have  tried as suggested the scripts both Zinstaller (graphical version ) , also as recommended ," installer.sh fully automated  for Linux (text version) " to set up the IDE with p32 and p8 compilers

No neither will work In fact they crash and don't install properly

I then also tried the link on this site  http://www.pinguino.cc/download/ide/  and extracted the file which creates x.4 installation

After doing this and starting the IDE What  happens is ... The IDE is a non responsive IDE in fact you cannot even resize the the frames  although you can at least close the window  but as for reading the example file They show in the frame LHS but you cannot pull the PDE code file into the code frame so as to view and compile

Then I chanced on your site and read through a couple of articles regards this and here again is reference to the x.4 ide and compiler but cannot see a solution for this on Linux Ubuntu 12.04 (i686)

I am to say quite frustrated  and could really do with some help and advise Ive not yet received any reply from http://forum.pinguino.cc


Can anyone offer me any advice at all reference this

Thanking anyone who might be able to throw some light on this or just simply where and how to get going with this


PS the git hub version works but withe the exit message as mentioned in the code block above

Cheers

Mark

JohnS

  • Hero Member
  • *****
  • Posts: 1666
  • Karma: +33/-45
Re: help with PIC32-PINGUINO-MX220 (newbie)
« Reply #1 on: December 28, 2015, 04:27:25 PM »
They've only has about 10 hrs to reply - and it's xmas hols for many :)

The Pinguino software (IDE etc) is a volunteer effort.  Yeah, it shows.  They're better at ideas than making solid code.  They rush to add new things without finishing old ones and also break working ones.

It's possible to get something that works and does so fairly well - or was, as I got a small number of versions working (looks like x.4 is one) and once "comfortable" just avoided any newer one.  There's a fair chance others and I can get you to a similar position.

I've used more than one Linux distro though not yours and they worked.  I've only got PIC32 boards (OTG & MX220 - the latter is short on flash so is OK for tiny stuff only, but that's a hardware issue really).

I gather you've figured udev needs some attention - or use root just long enough to prove all is working except udev.

First thing about your troubles that hits a vague memory is to get the PATH etc OK, or in the case of the -lgcc etc to get the LD_LIBRARY_PATH right.  I use this to start the IDE:
LD_LIBRARY_PATH=`pwd`/linux/p32/bin ./pinguino.py

I think what you now have is it in effect trying to access the libs from gcc rather than from its own cross-compiling gcc.

Oh, I should mention I'm not much of an IDE person.  I like my editor (the one I use all the time) so edit the file(s) and have been known to fire up the IDE just to compile and download the hex.

See if the above fixes it enough and maybe post - would you prefer here or the pinguino forum?  I can post twice but I'd rather not...

John
« Last Edit: December 28, 2015, 04:39:18 PM by JohnS »

Mark2016

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: help with PIC32-PINGUINO-MX220 (newbie)
« Reply #2 on: January 06, 2016, 07:54:47 AM »
I think you've hit this on the head

In to much of a hurry rather than produce something that actually works and then with repercussions for people who do produce reasonable hardware with no working real IDE 

Joint effort constant left hand knows not what the right hand is doing expecting all others to buy from them with no real working product

It is ever so slightly all wrong this story

Holidays yes brilliant ever heard of skeleton staff before  plenty of these people we all like skeletons after this story either ill or on very low wages expected to do the impossible with affluently wealthy people whom refuse to pay as well never mind doctors strikes It makes one step in the grave reality does it not

Not to worry we at least have one reply not bad I suppose ( Perhaps we should consider this miraculous )

JohnS

  • Hero Member
  • *****
  • Posts: 1666
  • Karma: +33/-45
Re: help with PIC32-PINGUINO-MX220 (newbie)
« Reply #3 on: January 09, 2016, 02:05:09 PM »
Who would these skeleton staff be?  There are NO staff.  Pinguino software that's giving you grief are ALL volunteers.

The hardware seems solid, at least to me the Olimex boards "just work".

John