Arduino IDE: using Linux, OS-X, Win first report and open questions

Started by winfried, November 25, 2015, 03:44:42 pm

Previous topic - Next topic

winfried

For a workshop I decided to get 10 ESP8266-EVB-BAT, seeing there is a Arduino-IDE now available.
Also ordered USB-Serial-Cable-F and a power-supply 5V.

So students are good tester falling in every possible trap I want to make just a first small report.
since we used linux-, OS-X and Win? laptops at the course:


A) install procedure indepent of the OS:
----------------------------------------

Download and install Arduino IDE > 1.6.5:

    - https://www.arduino.cc/en/Main/Software

for Olimex ESP8266 core environment use:

    https://github.com/esp8266/Arduino

In Arduino IDE under file->preferences URL:

    http://arduino.esp8266.com/stable/package_esp8266com_index.json

restart Arduino: in Tools->board->Boardmanager install the ESP8266 tools

select Tools->board->Olimex- MODWIFI...

3. Cabling the Serial debugging connection to programm

Connect cable on UEXT-Extension as follows::

    blue --> uext pin-2
    green --> uext pin-3
    red --> ext pin-4

Connect the USB-Serial Cable to your computer, choose the proper serial device unter Tools

4. Compiling, Flashing

Load example Blink and change Pin-number 13 to 5 (which is also the relay).
Compile, Then power on the  ESP8266-EVB-BAT holding button pressed and upload.

after a while the 1 second noise of the relay should be heard.


B) What did not work under the OS
---------------------------------

Linux Debian Jessie
~~~~~~~~~~~~~~~~~~~

Everything worked using the device /dev/ttyUSB0 on my laptop. Be sure to be member of the dialout group.

Mac OS-X
~~~~~~~~

1-2 worked fine.

But the serial cable does not work out of the box under OS-X

Serial Cable-F
..............

It should be named cu.serial under Tools-Port, else there is a need
to install the driver for the Profilic pl2303 for your OS-Version from here:

http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41

Compilation worked fine, but upload failed:

FAILED to flash
...............

The esptool for flashing does not work under OS-X. There was blog entry
to exchange it with esptool.py, so flashing worked but the programm didn't run...

(Any Hint ?)

Windows
.......

1-2 worked fine including compiling but serial cable was not recognized out of the box.

Serial Cable-F
..............

Before Installing the driver (if not already installed), unplug device during Installation to prevent to reboot.

Either use the driver mentioned here under Software:

- https://www.olimex.com/Products/Components/Cables/USB-Serial-Cable/USB-Serial-Cable-F/

- https://www.olimex.com/Products/Components/Cables/USB-Serial-Cable/_resources/win_x86_x64_drivers_usb_cable.zip

or direct from Chip Vendor of the USB2Serial Chip:

- http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=225&pcid=41

Afterwards the COM3 Port or higher should appear in the Arduino Menu: Tools->Port

Flashing on Windows 7 worked fine.

NOTE: under Windows~8 the serial driver did not WORK ! - Any hint ?


Conclusion
----------

Only with Linux everything worked out of the box. Mac OS-X was not usable and Windows~8 also not with this configuration.

Please help to solve the above, I will update this blog if success.
---- Atelier Algorythmics --- http://algo.mur.at/ ----

LubOlimex

Technical support and documentation manager at Olimex

KNK

Quote from: winfried on November 25, 2015, 03:44:42 pm
NOTE: under Windows~8 the serial driver did not WORK ! - Any hint ?


Goggle for "prolific usb to serial windows code 10" it is the same problem for Windows 8 and Windows 10 - you need an older driver and there is youtube video how switch to it after install