June 25, 2024, 05:51:03 PM

eMega missing bootloader

Started by khmweb, September 02, 2015, 05:10:42 PM

Previous topic - Next topic

khmweb

Using BUT + RST doesn't work no longer. Only the red LED works. I assume that the bootloader is damaged or deletetd.

Do I have any chance to repair the board? How can I do this? I'm a newbie ;) please be patient with me.

JohnS

Maybe a button is faulty.  Check with meter.

John

khmweb

#2
Thanks John.
I solved the problem yesterday. My power supply supplied the board with 5V only. Using one with a higher voltage (>= 9V <= 30 V) solved the problem immediately and I could re-program it.
I also was a bit confused when to use BUT + RST: I thought, that both are to use when I want to re-program it and for this I need the bootloader. I've learned something new. ;)

KeesZagers

Just for your information: you can power all Duinomite products with just 5 Volt. You have to power it directly on the USB connector. I just checked the current on the USB port. For the Emega I measure 0.14A and for the Mega 0.12A. So No problem for any USB port on a PC or other computer. USB power adapters are cheaper nowadays than a multi purpose adapter. Ofcourse the current will increase if you have a load on the outputs or add Arduino modules, etc. Normally an USB port can supply at least 0.5A.

Kees