Welcome, Guest

Author Topic: Issue in isp olimex lpc2378  (Read 2608 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Issue in isp olimex lpc2378
« on: July 20, 2015, 09:45:27 AM »
I am using olimex lpc2378 sdk and want to program the board using ISP via flash magic utility.

But this is not going to happening.
I tried as per following ...

Device LPC2378
Osc value 12 mhz
Baud rate 9600

Jumper rst and isp are closed.

I am confident  that communication between board and host is fine.

I tried open the board by pressing reset button and release it after clicking start button in flash magic gui.
It shows error that signature mismatched. But I have given correct device.

Please provide some hint.



  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Issue in isp olimex lpc2378
« Reply #1 on: August 18, 2015, 05:54:17 PM »
any suggestion here ?


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1642
  • Karma: +42/-2
Re: Issue in isp olimex lpc2378
« Reply #2 on: September 18, 2015, 11:34:21 AM »
Hello Sachin,

To be able to use Flash Magic with LPC2378-STK you need to set the board jumpers in correct positions first. Please set the respective jumpers in ISP_E and RST_E positions. Then plug the RS232 cable in connector RS232_0.

We now open Flash Magic, the settings are:

Select Device: LPC2378

COM Port: the number which our COM port cable is connected to (for example COM1, we can check in "Windows Device Manager" which is the correct COM number)

Baud Rate: 115200 (you can also use lower)

Oscillator (MHz): 12000

To test the connection you can select the ISP menu and attempt to "Read Device Signature".

Best regards,
Technical support and documentation manager at Olimex


  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Issue in isp olimex lpc2378
« Reply #3 on: April 14, 2016, 06:35:52 PM »
I have exactly that same problem. I did everything recommended. ISP_E and RST_E Jumpers are closed. Baud, com port, device and speed are set. When i click the start button on flash magic, board resetting itself but upload dont start. Flash magic says "connection problem" or "unknown signature".