Welcome, Guest

Author Topic: SIMON-85 troubleshooting  (Read 2133 times)

onekk

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
SIMON-85 troubleshooting
« on: January 19, 2015, 11:01:07 PM »
Bye to all, I have recently purchased the kit of SIMON-85, but the assembled kit didn't work as stated.

Some troubleshooting help is required.

I have checked the buttons between pin 2 and pin 4 of the IC (ATtiny85) and the button work changing the resistance.

The led are rotating after some time and so i suppose that the ATtiny is working.

What else should i check?

TIA

Carlo


LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1882
  • Karma: +47/-2
Re: SIMON-85 troubleshooting
« Reply #1 on: February 02, 2015, 11:29:42 AM »
Hello onekk,

What exactly is the problem in the behavior?

Please double check your soldering job as described here: https://www.olimex.com/Products/Duino/AVR/SIMON-85/resources/SIMON-85-ASSEMBLY-EN.pdf

If you are in doubt of the software try to download the newest version of the demo from the product page. Direct link to the demo: https://www.olimex.com/Products/Duino/AVR/SIMON-85/resources/SIMON-85_firmware_demo.zip

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

onekk

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: SIMON-85 troubleshooting
« Reply #2 on: February 06, 2015, 07:05:08 PM »
It seems that the buttons are not working, but io checked the at the pins 2 and 4 of the Attiny and the button are working modifying th resistor vallue.
I'm powering the board with the usb cable from a desktop computer.

If i press the buttons nothing happens, the led are rotating but no sound or other sign of life when presssing the buttons.

Regards

Carlo

olHelp

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
Re: SIMON-85 troubleshooting
« Reply #3 on: March 09, 2019, 03:29:19 PM »
It seems that the buttons are not working, but io checked the at the pins 2 and 4 of the Attiny and the button are working modifying th resistor vallue.
I'm powering the board with the usb cable from a desktop computer.

If i press the buttons nothing happens, the led are rotating but no sound or other sign of life when presssing the buttons.

Regards

Carlo

To add something here: I have the same behaviour with my recently assembled SIMON-85. However, if i plug it into a computer, not a charging plug, the Kit works as it should