Unable to connect to tool AVRISP mkII

Started by lhern034, January 15, 2015, 12:07:32 PM

Previous topic - Next topic


Zadig worked except for one person (who didn't run it as admin as it needs, if I understand the post).

Using an earlier AS is easy, though, I expect.

Or just use Linux :)



I downloaded and installed both atmel studio 5.1 and 7(although 5.1 never did run) but that did not help so I started messing with the firmware of the AVRISP mkII and reading from its datasheet and a few sources online made me try the usual procedure outlined in the datasheet and after pressing the update button and uploading new firmware and having the green LED now shine red instead it still did not work.

After a few hours of uninstalling and deleting devices in the device manager and re-installing firmware's it finally worked and I have no idea how I did it this time and I am at this point very confused about the hole thing.

But now atmel studio 7 can upload built solutions to my XMEGA Xplained A1.



And to be clear, Zadig didn't work for me.
It was about an hour ago that I stopped trying to use Zadig, so when I did make it work somehow it had nothing to do with Zandig. But it seems as a good thing that it has worked for everybody else.



Probably some combination(s) of Win X and AS Y that don't work but people often don't say their X & Y so impossible for anyone else to learn from their problems.



I use the MKII with Bascom-AVR. It works fine in Windows XP but not in W7.
I tried the solution with Zadig, but it did not help.
The driver always reverts back to "libusb0".
(after re-install to libusb-win32 and restart of Zadig)
Is this normal ?


I did a firmwareupdate of the MKII. The problem is solved. My previous project was in XP. For W7 and the new libusb you need more recent firmware.
Case closed.


Technical support and documentation manager at Olimex


I have the same problem like the others.

If I push "apply" under "Device Programming" in AtmelStudio7, I get the error:
Unable to connect to tool AVRISP mkII (0000A00128255)

Timestamp:   2016-02-12 17:28:22.289
Severity:      ERROR
ComponentId:   20100
StatusCode:   131103
ModuleName:   TCF (TCF command: Tool:connect failed.)

Could not read from libusb0 connection: libusb0-dll:err [_usb_reap_async] timeout error

I tried the "zadig 2.2" and also the driver, posted by LubOlimex (from February 01, 2016).
In my opinion the driver is Ok but the problem is still there.
I also tried it with Win7 64bit and Win10 64bit, but nothing was working and so I can`t use my OLIMEX Board to flash the Atmega8.

I hope anyone has a tip to slove the problem.

Sorry for my english and greets from Berlin

How can I insert a pic? sry


Hey Wolle,

In your case make sure to use these drivers: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip

Properly installed drivers in Windows 7 and Windows 10 should look as this:

Did you also update the firmware with the latest one (via Atmel Flip)? The latest firmware is found in this archive: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/AVR-ISP-MK2-Firmware-WindowsDrivers.zip

Best regards,

P.S. The forum doesn't support picture uploads - you need to host them to an image-hosting web-site and then link them in your post.
Technical support and documentation manager at Olimex


Hello LubOlimex,

so many thanks for your answer.
Last week I got a new MKII (clone). This device was specify for Atmel Studio 6 and higher.
And it is working now.

Despite of the sucsess, I´m owning now 2 MKII clones witch aren´t working with Atmel Studio 6 or higher.

You gave me the tip to flash the firmware with Atmel flip.
Now my new problem.
One clone includes an "Atmega32 A AU" and the other one an "Atmega8A AU". But both types of this chips aren´t listed in Atmel Flip, so I can´t flash them or get any connection/link to them. Is there any possibility to flash the two clone with the firmware you were written down in the text below?

How can I flash them or are they for the recycle bin (wast) now?

Thank you so much.

Greets Wolle


Great thanks! That works perfectly! But don't forget to reconnect your tool after changing driver (I forgot and so long I could't understand why it isn't working.)


Hi, I have Win10 on this laptop, Arduino IDE 1.6.7,the latests drivers for the MKII tooked from this site, firmware updated done via Flip,USB 2.0 port, but I'm still getting the same error message regarding "usb receive error"... This is what appears in the IDE's window:
avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\arduino-1.6.7\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): Found AVRISP mkII, serno: 000200312345
avrdude: stk500v2_recv_mk2: error in USB receive"

With the old IDE 1.0.6, works perfectly(same Win10 and PC), but with the IDE 1.6.7 it doesn't...
Can someone to give me a clue how to solve this annoying problem ?
Thank you..


Follow the instructions from chapter "2.3 Quick setup" from the user's manual blindly. I also use Windows 10. I tested a programmer taken from the store and I followed the instructions. "Upload using programmer" in Arduino IDE 1.6.7 works fine.

Here is a picture from few minutes ago: http://i.imgur.com/bskccvw.png

Check your hardware connections. Very often people think that AVR-ISP-MK2 has 6-pin ISP connector, which is not the case - there is only 10-pin ISP connector.

Best regards,
Technical support and documentation manager at Olimex


Hi,Lub....I did what the manual says,but I'll give another shot this evening..Maybe I did something wrong...Beeing in a middle of a project, I'll keep the 1.0.6 IDE on another PC, just in case...:)...I'll let you know about what's happening.Thanks for your support,Lub..
Best regards,

BTW, there are more than 2 years since I'm using this Olimex product, so forget about connectors mismatch..:)


Well, it doesn't works no matter I've done.
Steps i did :
1- updated the firmware again on the programmer, via Flip, hex taken from the manual's link,those for Avrdude...
2-deleted all the drivers for the programmer, updated from the drivers from the link,Device manager shows exactly like the manual's picture (libusb-win32, 27.01.206,Atmel,etc)...
3- Downloaded the Avrdude 6.2, the one is specified in the manual...
4- Launched avrdude, as administrator, but the error is the same.
   "avrdude: stk500v2_recv_mk2 : error in USB receive "
I really don't know ahat more things to do to make it works...
Any ideea, anything changed in hardware in the last two years ? ?
Best regards,