December 11, 2019, 07:45:52 am

Pic32 maxi web

Started by vachon31, November 22, 2012, 03:21:13 am

Previous topic - Next topic

vachon31

I've just bought a pic32 maxi web and im trying to build the demo projet. So i build the adcserver the freertos the graphicslib the sdcard lib and all is ok but when i buil the tcpiplib its tell me *** [build/default/production/_ext/1295770447/announce.o] error 1. I'm using mplab v1.51 i've try to build it with c32 and xc32 and i got the same error!! If some one could help me i'll appreciate

Thanks you, David

sdecorme

To try to clean your project before compiling it again ?

vachon31

November 22, 2012, 03:23:00 pm #2 Last Edit: November 22, 2012, 04:56:06 pm by vachon31
Yes i've try it and it doesnt work thats what is tell me


CLEAN SUCCESSFUL (total time: 260ms)
make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
make[1]: Entering directory `V:/Users/VACHON/Desktop/tso/PIC32Olimex/DemoSoft PIC32-MAXI-WEB v1.01 - MPLABX - Copy/DemoSoft/TCPIP stack_lib/TCPIP_lib.X'
"--------------------------------------"
"User defined pre-build step: []"
"--------------------------------------"
make  -f nbproject/Makefile-default.mk dist/default/production/TCPIP_lib.X.a
make[2]: Entering directory `V:/Users/VACHON/Desktop/tso/PIC32Olimex/DemoSoft PIC32-MAXI-WEB v1.01 - MPLABX - Copy/DemoSoft/TCPIP stack_lib/TCPIP_lib.X'
"V:\Program Files (x86)\Microchip\MPLAB C32 Suite\bin\pic32-gcc.exe" -g -x c -c -mprocessor=32MX795F512L -I.. -I../../CommonElements -I../../MainProgram -I../../Microchip/Include "-I../../Microchip/Include/TCPIP Stack" -Wall -MMD -MF build/default/production/_ext/1295770447/UDPPerformanceTest.o.d -o build/default/production/_ext/1295770447/UDPPerformanceTest.o "../../Microchip/TCPIP Stack/UDPPerformanceTest.c"
In file included from ../../Microchip/Include/TCPIP Stack/TCPIP.h:284:0,
                 from ../../Microchip/TCPIP Stack/Announce.c:65:
../../Microchip/Include/TCPIP Stack/Helpers.h:64:8: error: conflicting types for 'ultoa'
v:\program files (x86)\microchip\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/stdlib.h:96:15: note: previous declaration of 'ultoa' was here
make[2]: *** [build/default/production/_ext/1295770447/Announce.o] Error 1
"V:\Program Files (x86)\Microchip\MPLAB C32 Suite\bin\pic32-gcc.exe" -g -x c -c -mprocessor=32MX795F512L -I.. -I../../CommonElements -I../../MainProgram -I../../Microchip/Include "-I../../Microchip/Include/TCPIP Stack" -Wall -MMD -MF build/default/production/_ext/1295770447/Announce.o.d -o build/default/production/_ext/1295770447/Announce.o "../../Microchip/TCPIP Stack/Announce.c"
make[2]: Leaving directory `V:/Users/VACHON/Desktop/tso/PIC32Olimex/DemoSoft PIC32-MAXI-WEB v1.01 - MPLABX - Copy/DemoSoft/TCPIP stack_lib/TCPIP_lib.X'
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2
make[1]: Leaving directory `V:/Users/VACHON/Desktop/tso/PIC32Olimex/DemoSoft PIC32-MAXI-WEB v1.01 - MPLABX - Copy/DemoSoft/TCPIP stack_lib/TCPIP_lib.X'

BUILD FAILED (exit value 2, total time: 4s)

sdecorme

You're problem come from  error: conflicting types for 'ultoa'
Search in this forum I've read something about his , try to make your ultoa as comment to try

Good luck

LubOlimex

Hello vachon31,

Please refer to this message: https://www.olimex.com/forum/index.php?topic=206.msg829#msg829.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex