Welcome, Guest

Author Topic: Audio inputs broken on all Kernels for all Olimex IMX233 boards  (Read 2281 times)

benbiles

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
Audio inputs broken on all Kernels for all Olimex IMX233 boards
« on: October 08, 2014, 09:34:35 AM »
Hi,

The IMX233 boards audio inputs ( both line and mic ) have noise making it unusable on all available linux kernels. including official release 2.x and all 3.x kernels including when using this branch.

https://github.com/ITserve/imx23-audio

Therefore we can say Audio inputs are broken on this board?

Can anyone else confirm this?

ehsan51

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Audio inputs broken on all Kernels for all Olimex IMX233 boards
« Reply #1 on: January 27, 2015, 10:34:02 PM »
I have the same problem with microphone! :( I didnt test the line-in though! :(
https://www.olimex.com/forum/index.php?topic=4106.msg17385#msg17385
I use IMX233-mini-wifi and arch-linux.
« Last Edit: January 27, 2015, 10:36:24 PM by ehsan51 »

ehsan51

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Audio inputs broken on all Kernels for all Olimex IMX233 boards
« Reply #2 on: January 29, 2015, 08:10:10 AM »
Try
"amixer sset "ADC" xx% cap" xx < 100, it helps me to reduce noise.

ehsan51

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Audio inputs broken on all Kernels for all Olimex IMX233 boards
« Reply #3 on: January 29, 2015, 10:31:23 PM »
it helps to reduce the noise, but it was temporary. Sometimes it is clear , and sometimes it is noisy, sometimes it record nothing but "shshshhhhhh" sound!
Any help will be appreciate