STM32-E407 not working until JTAG connection

Started by tomoel, June 12, 2014, 03:54:52 AM

Previous topic - Next topic


I purchased STM32-E407 board and plugged power supply. The red LED turned on, but the green one remain dark.
After that I connected debugger hardware(ST-LINK/V2), the green LED turned on.
(at that time I didn't launch ST-LINK Utility nor OpenOCD, so ST-LINK didn't communicate with E407.)

I succeeded program LED flash demo (in Olimex ODS E407 sample).
But with E407 itself only, the green LED doesn't flash until debugger connection.
Once connected with debugger, the LED continues flashing after disconnecting debugger.

All jumper settings are default.

Any suggestions or guess?
Thanks in advance.


Hey tomoel,

1. How is the PWR_SEL jumper set?  It controls the powering. If it is in powering from JTAG position then this is a normal behavior.

2. Do you provide enough power to the board? I can imagine insufficient supply might cause such behavior (enough supply for the power LED, but not enough to power the processor or the user LED). Make sure at least 6V are supplied (you can measure it just to be sure, some power supplies might have misleading or erroneous labels).

3. What happens if you power the board from USB-OTG?

Best regards,
Technical support and documentation manager at Olimex


Thanks for your reply!
I checked your points.

1. PWR_SEL connects 1 and 2 (default). Confirmed using multimeter.
2. Measured at the power plug ('+' and '-') of E407. It was 9.16V. I think it is enough...
3. Even if choosing USB-OTG1(5-6), USB-OTG2(7-8), things remain same.
(At first, only red LED turns on and green one is silent. On connecting debugger, the green LED starts blink.)
When PWR_SEL is JTAG/SWD(3-4), it is normal. On connecting debugger, red and green LEDs wake up.

Umm... Would you hit another hints?

Best regards,


Hello tomoel,

I believe there is a hardware problem with the board. Either the jumper controlling the default powering is faulty or the circuit of the power supply is damaged. What caused it and how to repair it might be difficult to identify over distance.

I recommend you to return the board for inspection and repair or replacement.

Please read carefully the warranty and returns policy:

Please use the support e-mail - for further information.

Best regards,
Technical support and documentation manager at Olimex


Hello Lub/OLIMEX,

In short, I misconfigured B0_1/B0_0 jumper and E407 is fine.

I queried the shop from where we purchased STM32-E407 and send back.
Later they told us that it worked well and re-send us.

This time, the E407 worked fine with our power supply (9 Volts).

I found that the "B0_1/B0_0" jumper is the key.
When it is placed right, the green LED flashes (functional).
But when at left, the LED remain silent.
(*) E407's orientation is same as User Manual's, power-plug is seen at left-bottom.

Now it is clear and I can develop further.
(of course, I have to confirm the boot sequence...)
Thank you for your corporation!