New Kernel for A10-OLinuXino-LIME (3.4.67+)

Started by dl9hda, May 29, 2014, 03:12:45 pm

Previous topic - Next topic

dl9hda

Hello, I got my first lime. I tried raspberry pi but my application needs network and usb at the same time and the lime gives the little kick I need. I really need not more performance but better hardware.

But now I have a problem. cdc acm (serial via usb) is not in the kernel and so I wan't to reconfigure the kernel. But where can I find the souces?

I found this two pages:
http://eewiki.net/display/linuxonarm/A10-OLinuXino-LIME
http://olimex.wordpress.com/2013/12/13/building-debian-linux-image-for-a10-olinuxino-lime-with-kernel-3-4-67/

But the only useful thing is the a10lime_defconfig file. And of course I will not create a new sd-Card image.

Years ago with gentoo linux on my pc I did things like this:


root@linux # make menuconfig
root@linux # make
root@linux # make modules_install
root@linux # cp /boot/vmlinuz /boot/vmlinuz.old
root@linux # cp /usr/src/linux/arch/i386/boot/bzImage /boot/vmlinuz
root@linux # cp /usr/src/linux/System.map /boot/System.map-<kernelversion>

Is there a faq or a manual how I can rebuild the kernel?


best regards
Holger


olimex

the blog have step by step instructions how to build the kernel with 3.4.67+, what is your problem to follow these steps?

dl9hda

Yes I did.  Running kubuntu 14.04.

The first problem:

root@blackmashine:/home/holger/A10_kernel_3.4/u-boot-sunxi# make A10-OLinuXino-Lime CROSS_COMPILE=arm-linux-gnueabihf-
make: *** Keine Regel, um »A10-OLinuXino-Lime« zu erstellen.  Schluss.
root@blackmashine:/home/holger/A10_kernel_3.4/u-boot-sunxi#

This is German and it means no rule to make target.


best regards
Holger


scout_3pm

Read again the HOWTO carefully !
You have to give targer, i.e: uImage, modules or modules_install !!

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- uImage

READ CAREFULLY THE HOWTO ! Do not rush it.
Good Luck


JohnS

Which part of the how to failed or did not do what you want?

It looks complete...

John

dl9hda

May 31, 2014, 06:09:03 pm #6 Last Edit: May 31, 2014, 11:18:19 pm by dl9hda
Hello, I got it. There are some errors in the blog but I got it.

So far so good.

Another question: How do I enable the boot messages? A short time after connecting the power supply I can see, that the hdmi outpout works but there is only a black pane. After connecting to the network X starts. But no messages on the display like booting a rpi with raspian.


kind regards
Holger

MBR

To see the boot messages, the kernel parameter console must be set to tty1 and console loglevel (parameter loglevel) must be set to sane value (the default is OK). The parameter quiet must not be set (it mutes all boot messages). To get the maximum of messages, the framebuffer driver must be built into the kernel (not module). Optionaly, compile the kernel with the boot logo enabled a get a nice penguin (on the same place where RPi displays a raspberry).

charlieholimex

I'll continue this thread, as the subject line is suitable.

I'm also trying to follow the blog, and having problems.

I am on Mint 13/Ubuntu 12

When I get to this line:
make A10-OLinuXino-Lime CROSS_COMPILE=arm-linux-gnueabihf-

It says I'm not configured, and to read the README

The README tells me I need to configure for whatever board I'm using. So I tried:
make A10-OLinuXino-Lime_config

It seems to have been happy with that.

But then when I come back to:
make A10-OLinuXino-Lime CROSS_COMPILE=arm-linux-gnueabihf-

It says:
make: *** No rule to make target `A10-OLinuXino-Lime'.  Stop.


charlieholimex

After make A10-OLinuXino-Lime_config, I just left the target off of the
make A10-OLinuXino-Lime CROSS_COMPILE=arm-linux-gnueabihf- command.

Thus:
make CROSS_COMPILE=arm-linux-gnueabihf-

The make succeeded, and my new kernel and distro boots up and works fine.

kermit80

Hi, me too I've been stuck at the same point.
I've resolved following the linux-sunxi wiki:

make CROSS_COMPILE=arm-linux-gnueabihf- A10-OLinuXino-Lime_config

and then:

make CROSS_COMPILE=arm-linux-gnueabihf-

It seems to be about the same of what you've done.

dl9hda

June 15, 2014, 06:22:02 pm #11 Last Edit: June 15, 2014, 06:24:21 pm by dl9hda
Hello,

I figured out some stupid misbehavior of my firefox 30.0 (kubuntu 14.04) with this website: http://olimex.wordpress.com/2013/12/13/building-debian-linux-image-for-a10-olinuxino-lime-with-kernel-3-4-67/

The content of the webpage depends on the font-size (try ctrl with + or ctrl with -). With the wrong font-size some lines are cutted off. For example:

# apt-get install gcc-4.7-arm-linux-gnueabihf ncurses-dev uboot-mkimage build-essential --> wrong
# apt-get install gcc-4.7-arm-linux-gnueabihf ncurses-dev uboot-mkimage build-essential git --> correct


So the best is to copy the hole content into an editor like kate or so and then follow the steps.



best regards
Holger