i.MX233 Olinuxino Micro can't boot.

Started by Rubid, May 15, 2014, 05:04:31 pm

Previous topic - Next topic

Rubid

Hi!
I've recently bought a new i.MX233 Olinuxino Micro board.

The problem is that it can't boot. I've seen that problem here on forum, but none of the soultions worked for me. The last message I can see while booting is the problem with low voltage on battery.

1. I don't have R17 resistor soldered on board.
2. I'm using my own Kingston Class4 1GB MicroSD card. More cards (Transcend 16GB Class10, ADATA 8GB Class4) are already bought, I will test them in near future.
3. I've tried to boot with Open Embedded Linux Kernel and Linux Kernel with LTIB. I've also used Debian and Arch filesystems.
4. I'm using regulated voltage source connected to LM7805 voltage regulator, which gives me 5,02V at the end.

Below I attach the screenshots when booting using noth kernel versions (Open Embedded Linux Kernel and Linux Kernel with LTIB).

Any help will be appreciated.

Cheers.




Kean

Based on my experience, this is typically a power supply problem or a bad microSD.
Can you tell us more about the "regulated power supply"?
If the power supply connected to the LM7805 can't supply enough current, then there won't be enough for the CPU.
If the input voltage to the LM7805 is too high, then it could overheat and could cause thermal shutdown.

Rubid

Hi Kean,
its a 3A, 0-15V regulated lab power supply. It's set to about 6.5V. The current is not limited (3A). I measured voltage at LM7805 output and it shows about 5.02V. Olinuxino Micro should be powered by exactly 5V so I think that it's OK. LM7805 is not even warm.

Cheers!

Kean

OK, sounds good - just making sure.  I assume you have some caps on the LM7805?

I suggest testing additional microSD cards.  Never had a problem with Team Micro 2+GB Class 4 or better, on about 500 cards deployed on a derivative hardware design.  Sandisk has also been fine, although they're not my favourite as they can fail in annoying ways, and they're also very commonly faked.

I recall having had some random cards (other brands) that I believe showed similar boot failure symptoms, and I just chucked them.  I've also had to reseat SD cards to fix booting issues, but that's pretty rare (depends a lot on connector used).

Kean

Actually, depending on the brand of LM7805, 6.5V may be a bit too low.  I think some require 2V headroom (I typically use low dropout versions).

Try 7.5V input.

Rubid

Kean,
it worked like a charm!

Thank you so much, for such a simple solution!

Regards.