June 13, 2024, 09:27:11 AM

ATTiny167

Started by kpayea, May 12, 2014, 09:22:06 PM

Previous topic - Next topic

kpayea

Hi:

I have an AVR-ISP500 which I am using with Atmel Studio 6.1.  Will it program the ATTiny167?  It doesn't show up as a valid device under Device Programming.  I bought the ISP-500 very recently, but the ATTiny 167 is also relatively new.  Do I need a firmware update for the ISP-500?

Thanks!

LubOlimex

Hey there,

Do you mean that ATTiny167 doesn't show as a supported device (in the drop-down list of microcontrollers) in Atmel Studio 6.1? If it is so then do the following:

The key thing is you need to add a couple of .xml files for the processors you'd like to program. The correct folder is located in YOUR_INSTALL_DRIVE\Program Files (x86)\Atmel\Atmel Studio 6.x\tools\STK500\xml. There you need to edit an xml with a text editor by changing the default name of the .xml to the pattern of the other xmls and edit the processor name inside. The rest should remain unchanged.

Please also check this very nice guide on adding devices in the xml: http://www.pololu.com/docs/0J36/3.b.1

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex