UART0 - supplied debian image - TTL - can not receive data

Started by Lirezh, April 16, 2014, 05:12:16 am

Previous topic - Next topic

Lirezh

I used the latest debian image and boote up the lime.
I connected a TTL uart-usb converter configured to 3.3V (it works fine on AVR)

I can not receive any byte on PC.

I hooked up an oscilloscope to the TX of the LIME, I can see an echo of my input.
The frequency reflects the frequency I use (tried various ones), so it seems the board adapts to the input.
However, the serial driver on PC side does not get any bytes.


Of ourse I disabled any flow control, etc.

I am really puzzled.
If the UART converter would not work fine with my atmel I would suspect it is dead.

Any idea where the problem might be ?

Lirezh

I replaced the USB-TTL-UART module and it suddenly worked!

I was using an FTDI FT232RL chip, it could not receive data!
It works perfectly for a ATmega8a, I am puzzled.

Now I use a CP2102 converter which works.

Lurch

Could be something about the FTDI FT232RL or the wires you used.  I use them on all of the A10, A13 and A20 boards I have and they work OK.  Bad connection maybe?  Try another USB slot?

Lirezh

Same cabling, same usb port, different TTL chip and it works.
Back to the FTDI and only sending works, both work with my AVR.

Difficult to say what the reason was, must be something very low level on signal layer.