Welcome, Guest

Author Topic: Boot A10S from NAND (Français)  (Read 4650 times)

habanas

  • Jr. Member
  • **
  • Posts: 50
  • Karma: +0/-0
Boot A10S from NAND (Français)
« on: March 27, 2014, 01:22:09 PM »
Bonjour.

après avoir pas mal joué avec mon A10S-NAND 4Go, je tente une nouvelle manip qui me permettrai de démarrer a partir de la NAND sans avoir besoin de carte SD .
Je découvre doucement les différentes actions a effectuer et je ne suis pas toujours sûre de bien comprendre ce que je fais.
la carte est livrée avec un version Android directement sur la NAND j'aimerais passer sur un Debian
j'ai essayer de suivre les instruction de cette article :
http://linux-sunxi.org/Installing_to_NAND
j'ai effectué le partitionnement de la NAND selon ce schéma
2 partitions
partition  1: class =         DISK, name =   bootloader, partition start =    32768, partition size =    32768 user_type=0
partition  2: class =         DISK, name =        linux, partition start =    65536, partition size =  4816896 user_type=0


J'arrive a la Partie du U-boot (http://linux-sunxi.org/U-Boot#Get_a_toolchain) ou je tente de compiler ce dernier.
Je récupère bien le repertoire : git clone https://github.com/linux-sunxi/u-boot-sunxi.git
la commande grep sunxi boards.cfg | awk '{print $7}' m'affiche bien les différente version du U-boot
mais lorsque je compile cela ne fonctionne pas :
make CROSS_COMPILE=arm-linux-gnueabihf-A10s-OLinuXino-M
Makefile:485: *** "System not configured - see README".  Stop.

Il semblerais que je n'ai pas arm-linux-gnueabihf je n'arrive malheureusement pas a le récupérer .

Voila si quelqu'un à déjà réussi a réaliser cette manip, je suis preneur de renseignements et même d'explications sur les différentes étapes de réalisation .

Merci





 

MANU62170

  • Newbie
  • *
  • Posts: 34
  • Karma: +0/-0
Re: Boot A10S from NAND (Français)
« Reply #1 on: April 15, 2014, 01:33:25 PM »
Bonjour à tous les francoiphones.

En français cette fois, le message que je viens de poster en anglais.

Mon A10S tourne (enfin:-) ) depuis la carte micro SD, aussi bien sous Android que sous Debian.

Pour rappel, jusqu'à  très  récemment, mon OlinuXino A10S n'avait jamais fonctionné: il bloquait au bout de quelques secondes de démarrage d'Android depuis la NAND.

Toutes mes tentatives pour réinstaller l'image NAND Android en suivant la procédure d'Olimex étaient restées vaines: le PC, sous Windows ne reconnaissait tout simplement pas la NAND pour y installer l'image (en utilisant le petit logiciel imagedisk builder, je ne suis pas sûr du nom).

Hier , j'ai eu l'idée d'installer gparted sous Debian, depuis la carte micro DS. Et là, surprise, la NAND apparaît comme partition inconnue.

Donc je me demande si je peux SANS RISQUE tenter de reformater le NAND en Fat 32 avec gparted, de sorte qu'ensuite la NAND ait des chances d'être reconnue sous Windows et que je puisse enfin  réinstaller l'image NAND et booter depuis la NAND.

Merci d'avance pour les réponses, et bonne journée  :)

R.D.

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Boot A10S from NAND (Français)
« Reply #2 on: May 01, 2014, 06:48:10 PM »
Hi!!!
Who can make how to for making u-boot to start Linux from NAND,
or put u-boot.bin anywhere..... for download if you have....

martinayotte

  • Full Member
  • ***
  • Posts: 125
  • Karma: +2/-0
Re: Boot A10S from NAND (Français)
« Reply #3 on: May 06, 2014, 07:49:21 PM »
Hi R.D,

I don't know if you speak French or not, but here is a recipe I used to boot from NAND on A10s awhile ago :

https://www.olimex.com/forum/index.php?topic=1628.0

For Habanas, I will continue in French :

Je vois que vous avez pu partitionner la mémoire NAND correctment, mais que vous n'arriver pas à compiler le U-Boot, ayant le message "System not configured - see README". C'est parce qu'avant de faire la commande de compilation, il faut preparer les Makefiles en configurant, c'est à dire faire un "make <boardname>_config", de mémoire, j'avais fait "make sunxi_config", du moins à ce que je me rappelle et ce qui est mentionné dans le README de U-Boot.

Espérant que ça aide/Hoping this help,
Martin

R.D.

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Boot A10S from NAND (Français)
« Reply #4 on: May 15, 2014, 07:38:58 PM »
Hi martinayotte!
I dont speak French.... Only english, rusian, ukrainian :)
I saw this is manual https://www.olimex.com/forum/index.php?topic=1628.0, but i cant make working boot file. I change parametrs in file sun5i.h (sun4i.h for a10 cpu) but i have a error and device boot from mmc :(
Can you explain how you make working boot? You can post working boot or post fixed sun5i.h... and and I try make boot?
« Last Edit: May 15, 2014, 07:43:28 PM by R.D. »

martinayotte

  • Full Member
  • ***
  • Posts: 125
  • Karma: +2/-0
Re: Boot A10S from NAND (Français)
« Reply #5 on: May 17, 2014, 06:24:40 PM »
Hi R.D.,

The only thing I've edited in sun4i.h is the CONFIG_BOOTCOMMAND itself.
I don't remember any other special stuff I had to do other then what is described in recipe.
Since I've switched to A20 since several months, I'm not using my A10s anymore.

What kind of error you've got before it fall back to the MMC ?


R.D.

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Boot A10S from NAND (Français)
« Reply #6 on: May 22, 2014, 03:21:33 PM »
hi!
I made some fix and make boot. Hi have this is parameters:

sun5i# printenv
bootargs=root=/dev/nandb console=ttyS0,115200 rootwait panic=10
bootcmd=setenv bootargs root=/dev/nandb console=ttyS0,115200 rootwait panic=10 ${extra}; fatload nand 0 0x43000000 script.bin; fatload nand 0 0x48000000 linux/uImage; bootm 0x48000000
ethact=emac
stderr=serial
stdin=serial
stdout=serial

Environment size: 314/131068 bytes
sun5i#

But i have this error:
Wrong Image Format for bootm command
ERROR: can't get kernel image

martinayotte

  • Full Member
  • ***
  • Posts: 125
  • Karma: +2/-0
Re: Boot A10S from NAND (Français)
« Reply #7 on: May 23, 2014, 04:21:41 PM »
Unfortunately, I don't have much other clues.
Probably the uImage you placed in the linux/ folder isn't good.