Welcome, Guest

Author Topic: Unable to install drivers  (Read 3593 times)

glims

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Unable to install drivers
« on: March 22, 2014, 06:31:35 PM »
It seemed so easy... I plugged in the EEG-SMT device and followed the quickstart guide. When I reached the point about changing / updating the drivers, windows (7) told me that the dirvers were up to date...

device registers as USB Serial Port (COM6). There is no option to install anyways. Definitely no "have a disk" option. No one has disks -_-  It just let's me know that my usb drivers are up to date. OLIMEX does not show up  in "other devices". There is not "other devices".

Attempted to run Openvibe acquisition software. Get the warning,
No 'plugin object descriptor<s> from [C:Program..blah blah location../openvibe-plugins-vrpn.dll]
Registry key is not initialized.
And then we hang up at Loading Plugin: Software Tagging

The interface opens and I can connect. But pressing play gets the 'did not receive anything from driver" error.

Since I couldn't update those drivers, I'm going with driver issues. Any way to brute force install the FTDI drivers from the website?

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1968
  • Karma: +50/-3
Re: Unable to install drivers
« Reply #1 on: March 28, 2014, 01:10:54 PM »
Hey there,

The behavior described suggest either an occupied COM port or a driver-related problem.
 
Try changing the COM port number – this can be done from the “Windows Device Manager”, go to the advanced settings of the port and change the COM number. Please also test  with “Electric Guru” initially (it works only with COM 1 to 4 so make sure to set the COM to one of these #) – it requires the least settings adjustments which limits the software errors. Electric guru might be downloaded from EEG-SMT’s web-page.
 
Usually to be able install the drivers from the web site you first need to uninstall the drivers already installed. When uninstalling the drivers under Windows remember to remove both occurrences of the FTDI drivers in the COM & LPT section and in the Universal Serial Bus controllers section of Windows Device Manager. Please refer to the image below:
 

 
It is imperative that the automatic driver installation is disabled in the Windows settings. Else it would download some erroneous version of drivers off the Internet every time you plug the device.
 
Please try with these driver: https://www.olimex.com/Products/_resources/FTDI_drivers_2.04.06.zip.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

glims

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Unable to install drivers
« Reply #2 on: March 28, 2014, 07:13:00 PM »
Thank you for the reply. I found that this specific sequence allowed the device to work.

First, disable automatic installation of device drivers in windows.

Then, plug in the device. The previous default driver that were installed will show up in Device Manager.

Uninstall them by going to preferences->drivers->uninstall(advanced) and select remove the downloaded drivers check box. This is important, as not doing this will just cause Windows to refer back to the drivers you previously uninstalled.

Unplug the device and restart your computer.

Plug in the device. You will get an error message. Find the device with the yellow exclamation mark in Device Manager. Right click and choose Update Drivers and choose to hunt for them on your own.

Search for the custom drivers from the olimex website and install them.

Windows may pop up an error in the task bar saying that the drivers did not install correctly. However, I was still able to use the acquisition software, Windows is just confused.


Thank you for you help :)