olimexino-stm32 and ARM-JTAG-COOCOX error on flash...

Started by arsieroluca, March 12, 2014, 06:13:57 pm

Previous topic - Next topic

arsieroluca

Hi all!!

I recently buy this board and this programmer and I started to use these just now.

After three attempt of load and try firmware I have done a big mistake.

I tried to load an old fw binary for NXP chip... after that if I try to erase or re-program the CooCox Flash say "flash driver function execute timeout".

If I try to verify program (with old binary) the CooCox say good and the black check work properly (I tried to test many sector and from the #37 the flash is empty).

Have someone this kind of experience?

Thanks a lot!!!





JohnS

I think that board is SWD and I am unsure if SWD can always recover a board but the good news (in case it can't) is that the BOOT0 / BOOT1 pins allow an on-chip bootloader to be put in control.  So, worst case you can reflash the board that way - see the chip datasheet and the ST doc such as AN2606 / RM0008 / PM0056 for fuller details.

John

arsieroluca

Thank you John for your replay!!

Yes it seems the SWD isn't able to recover my board... I know the boot0/boot1 possibility... but is not more simple to do in my board...

But just now you have confirmed this way... :(

Thanks a lot!!

LubOlimex

Hello,

OLIMEXINO-STM32 and ARM-JTAG-COOCOX work together but you might need an adapter for the small 10-pin connector (like this one https://www.olimex.com/Products/ARM/JTAG/ARM-JTAG-20-10/; or just use jumper wires accordinly). OLIMEXINO-STM32 can be programmed both via JTAG and SWD interface. The binaries required to flash the bootloader might be downloaded from here:

https://www.olimex.com/Products/Duino/STM32/OLIMEXINO-STM32/resources/OLIMEXINO_STM32_binaries.zip

You can use CoFlash to download them to the board.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex