Big problem: brandnew new A10S OlinuXino does'nt start. Help please !

Started by MANU62170, March 06, 2014, 06:35:26 PM

Previous topic - Next topic



I'm french and bought instead of a Raspberry an  A 10 S OLinuXino by Olimex because of its benefits, to use it as computer on  my TV.

I specify I've been using Linux on my PC and on my notebook for more than 6 years, so I know Linux ... After Mandriva I now use Mint 13 (KDE). I've got Windows 7 too on my PC (dualboot).

I got the A 10 S OLinuXino without any SD card. So I've put an ext4 formated 16 Gb SD-Card into the SD-slot.

I've got a big problem with my Olimex OLinuXino A10S, since the first time I connected it. I tried many times to find a solution, but it still doesn't work, although I'm almost sure it's not a hardware problem.

When I connect it on the TV,  it first seems to work: the Android bot appears a few seconds, like on a Android tablet we've got. But after a few seconds the Android bot disappears, the word "ANDROID appears and beginns to flicker. Then it last hours and nothing happens, "Android just still flickers...

I first thought the Olimex OLinuXino A10S needs first to download something, before it really starts (if for instance just  an installing program is pre-installed when you get it). But after many hours, there's no change: "Android" still flickers...

I of course tried to restore the (theoretically? I'm actually not sure) preinstalled software, following the Olimex A10S Olinuxino user's manual, but there was no change (I maybe did something wrong, I'm not sure I  use correctly the little buttons or connect the A 10 S correctly on my PC: USB? micro USB?...).

It would be very very very kind if somebody could help  me to find the solution, leading me step for step.

If I've got to connect the A10S on my PC, I can start it under Windows 7 or Linux Mint  13. It's of course better, if I can use Mint 13. I of course maybe have to download a program and an Android image, then give me please the links....

Thanks a lot, I'd rather not to have to  throw the A 10 S away and buy a Raspberry :-)



Hello, John!

No, I think the power supply unit is ok... I tested it...

Maybe somthing else?

Is the os (Android) allways allready fully pre-installed when you buy the A10S?

Can I use a 16gb SD micro-sd card?

Is there any possibility to try to boot it just from the micro-sd? With which OS?

Thanks a lot for further advices...  :)


As a number of us have pointed out on the forum, a serial debug cable is a real godsend when trying to figure out what is going on in situations like this.

The flickering Android is a good sign. This appears during the boot sequence and it can take a few minutes for the first ever boot as Android expands and formats the system so something is wrong if it never does past this point.

If you don't have the serial debug cable, if you plug in a USB cable, do you hear any beeps as the board boots. Once the Android wording appears, the system should have the USB ADB drivers running so if you have ADB on your computer, you should be able to run the likes of Android Studio and see the logcat.


Thanks for the an, Dave.

I've no serial debug cable and  I don't know how it has to be connected. I'm just beginning with such boards.

I have pluged in a mini USB / USB cable (mini USB on A10S board, usb on my home PC), and I didn't hear any sound...

Could you tell me if I must try to restore the nand,and tell me step by step wha I've got to do (from my linux Mint 13 dektop or from my Windows 7 desktop? With the links to the programs or images I've got to download.

Thanks for the help  ;)