Welcome, Guest

Author Topic: QT 5.2.1  (Read 4426 times)

fiosca

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
QT 5.2.1
« on: February 21, 2014, 02:33:55 AM »

I'm not following the standard cross-compiling approach (I have only a Macbook at the moment and
couldn't find a way to install arm-gcc on Mavericks) but trying to build everything on the board.

I'm receiving a lot of compiling errors, even if all required packages had been installed.
Did anybody manage to build QT 5.2.1 for A10?

00depp80

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #1 on: February 24, 2014, 08:37:00 PM »
Use VIrtualBox + Ubuntu/KUbuntu for standard cross-compiling.

I working on QT 5.2.1 for my self. I can provide installation instructions when I have finished

fiosca

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #2 on: February 24, 2014, 09:46:50 PM »
Great! I have a Debian on my VirtualBox with an ARM toolchain (used to compile the Linux kernel).

I tried to download the QT sources but could not manage to cross-compile them because
Allwinner devices seem not to be supported directly.

What is your "./configure" string?

00depp80

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #3 on: February 24, 2014, 10:01:19 PM »
See here
http://linux-sunxi.org/Qt5
or
http://www.ics.com/blog/building-qt-5-toradex-t30#.Uwujm0J5Nqc

On the board
 ./configure -release -opensource -confirm-license -opengl es2 -no-eglfs -no-linuxfb -no-pch -plaform linux-arm-gnueabi-g++

I have not tried.
May be I try it tomorrow.


dave-at-axon

  • Hero Member
  • *****
  • Posts: 625
  • Karma: +18/-0
Re: QT 5.2.1
« Reply #4 on: February 25, 2014, 03:37:24 AM »
How much work is there is getting cross compilation and then debugging on target working?

I have an A10s running Debian with the xfce desktop and I want to learn how to develop GUI based apps for it. I would prefer to design on the desktop under a VM (as I run Windows as my main OS) or native from Windows and then download and debug on the target board. Is this possible? It's one of the reasons I love doing Android or NETMF dev. :)

fiosca

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #5 on: February 25, 2014, 11:33:48 AM »
Hi 00depp80!
Tried both way but with no results.

Cross compiling:
--------------
1.  "gcc-4.7-arm-linux-gnueabihf" toolchain from http://www.emdebian.org/ is ok for kernel building,
but linker (ld) seems not to support correctly the --sysroot option (it doesn't apply sysroot correctly, found many complains in many forums).

2. Linaro toolchain returns different errors, always from linker
"relocation R_ARM_THM_MOVW_ABS_NC against 'a local symbol' can not be used when making a shared object; recompile with -fPIC"
Of course the "-fPIC" does not refer to QT but mainly to static libraries on the filesystem.


Native Building:
--------------
1. Even if it takes hours and hours to build, with the "configure" string you mentioned I receive a compiler error (a sort of syntax error on one include). I'm using the standard Debian image provided by Olimex.


It looks like a nightmare! Can you provide us with a small guide about how to compile QT5?

00depp80

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #6 on: February 26, 2014, 07:14:40 PM »
On Device i've these configure options:
./configure -release -opensource -confirm-license -opengl es2  -no-pch -qt-xcb -no-c++11

Update:
Important is -no-c++11.
I've installed g++-4.7 libgles2-mesa-dev libglu1-mesa-dev libgles2-mesa-dev
see here for installation of g++-4.7 http://askubuntu.com/questions/26498/choose-gcc-and-g-version
I have not yet tried the build toolchain.

 ./configure -release -opensource -confirm-license -opengl es2 -no-eglfs -no-linuxfb -no-pch -platform linux-arm-gnueabi-g++
« Last Edit: February 27, 2014, 10:16:02 PM by 00depp80 »

00depp80

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #7 on: February 28, 2014, 07:47:40 PM »
I've installed g++-4.7 libgles2-mesa-dev libglu1-mesa-dev on olimex device
configured qt 5.2 with these options
./configure -release -opensource -confirm-license -opengl es2  -no-pch -qt-xcb

and could build successfully on olimex device.

I have not tried to build qt with the crosstoolchain.

lbalas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: QT 5.2.1
« Reply #8 on: March 05, 2014, 05:44:45 PM »
Hi 00depp80,

can you please write down step by step the installation procedure?

Sorry, I am beginner in Linux.

I would like to use the QT 5.2.1 on my A10 obard with the official Olimex Linux.

Thank you in advance

lbalas