EEG-SMT Win 8.1 Installation failed.

Started by sunstone, February 19, 2014, 07:46:47 pm

Previous topic - Next topic

sunstone

Hey! I'm trying to install the device on Windows 8.1. I haven't installed before but I'm trying to follow the instructions. After I have downloaded(CDM v2.08.30 for Windows 8.1) & manually installed(ftdibus.inf) the drivers USB Serial Converter (+A-C) windows informs me that it's failed after all. Is this new bug?  :-\

LubOlimex

hey sunstone,

Can you provide some more details on what exactly failed. Is there an error in the device manager? Is it possible that Windows 8 blocked the drivers?

Could it be the problem with the newest drivers that was related to an FTDI chip in the EEG-SMT. Description and solution of the problem might be found here: https://www.olimex.com/forum/index.php?topic=2031.0?

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

sunstone

This is the thing what happens. I insert the device and see yellow triangle with exclamation mark on the device in the device manager.. When I look into the update driver part there is this text on the driver "Device descriptor request failed" or "This device cannot start. (Code 10) A request for the USB device descriptor failed."

Then I install the drivers again manually and select the .inf that was supposed to be used ftdiport.inf. The drivers get installed and right after that there is this usual windows sound "di di dI dI" and I see the yeallow triangle again with comment on the right down corner of the screen.. This is the same situation again. I have tried now that zip CDM 2.04.06 WHQL Certified but the problem remains the same hmm..

sunstone

February 24, 2014, 02:20:12 pm #3 Last Edit: February 24, 2014, 02:41:58 pm by sunstone
Hey wait.. Now I realized that there maybe something wrong with my usb port because I was using extension cable. When I now changed the port my mouse went wild! So I think I'm close to make it work am I? ;D

EDIT: Okay sorry. Now it's not working again :( Same problem again. Hmm.. The red light is also only visible in the device for something like 0,1 second and goes off. Is this normal? Okay now that light also seems to have it's own spirit. It lights up when he thinks it's the time to be red.

sunstone

March 06, 2014, 09:40:00 am #4 Last Edit: March 06, 2014, 09:48:15 am by sunstone
New status.

Okay when I uninstalled the serial converter. I got it again working in similar fashion as before: Mouse goes wild. Hmm. Now I know how to do that. Then problem is how to use the mouse. Hmm could this be avoided using USB-mouse? Okay it seems to work now. Just had to repeat the process. Strange, huh? :)

sunstone

March 06, 2014, 09:55:09 am #5 Last Edit: March 06, 2014, 10:10:36 am by sunstone
Okay here is the final status. But now I cannot get any readings in BrainBay. And the device light is red. Should it be red?  :-\ This is what I got from neuroserver "Serial packet sync error -- missed window.".
EDIT: Okay I don't know how but it seems that BrainBay started to work properly.. Magic.



sunstone

March 07, 2014, 04:48:09 pm #6 Last Edit: March 07, 2014, 06:40:55 pm by sunstone
Hey. I'm getting the mouse problem all the time. When I plug the device to PC the mouse starts jumping and clicking and basically just messes up the current run of OS.. Is there a way to overcome this thing? I cannot use this device at all currently because of this. :-\ Please, help me!
EDIT:
Okay there was well documented solution in the manual after all! Thank you! The regedit-solution seemed to work for me. Didn't try the first solution though https://www.olimex.com/Products/EEG/OpenEEG/EEG-SMT/resources/EEG-SMT.pdf

sunstone

I got the device working properly on my PC. Then the only thing is that in some other PCs it's seemingly impossible to do it. Just change PC until you find the right one If there are problems. But anyway. Solved  :)