Welcome, Guest

Author Topic: Lime - es2gears libEGL warning: DRI2: failed to open lima  (Read 5025 times)

kruno

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Lime - es2gears libEGL warning: DRI2: failed to open lima
« on: February 19, 2014, 07:00:38 PM »
using the latest sd card image from:
http://olimex.wordpress.com/2014/01/15/building-debian-linux-bootable-sd-card-with-hardware-accelerated-video-decoding-and-kernel-3-4-for-a10-olinuxino-lime/

root@a10Lime:~# es2gears
libEGL warning: DRI2: failed to open lima (search paths /usr/lib/arm-linux-gnueabihf/dri:${ORIGIN}/dri:/usr/lib/dri)
EGL_VERSION = 1.4 (DRI2)
vertex shader info:
fragment shader info:
info:
78 frames in 5.0 seconds = 15.501 FPS

Any help is appreciated.

fw72

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Lime - es2gears libEGL warning: DRI2: failed to open lima
« Reply #1 on: March 10, 2014, 12:24:18 PM »
Did you find out how to solve this problem? I'm stuck at the same point...  :-\

Metanurb

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Lime - es2gears libEGL warning: DRI2: failed to open lima
« Reply #2 on: June 03, 2014, 03:20:25 PM »
I have the same problem here  :(

Metanurb

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
[SOLVED] Re: Lime - es2gears libEGL warning: DRI2: failed to open lima
« Reply #3 on: June 03, 2014, 04:25:25 PM »
I got it running with the sunxi-mali drivers.

Code: [Select]
git clone https://github.com/linux-sunxi/sunxi-mali.git
cd sunxi-mali
git submodule init
git submodule update
sudo make install

# move the lima drivers out of the search path:
sudo mkdir /usr/lib/arm-linux-gnueabihf/bak
sudo mv /usr/lib/arm-linux-gnueabihf/libGLES* /usr/lib/arm-linux-gnueabihf/bak
sudo mv /usr/lib/arm-linux-gnueabihf/libEGL* /usr/lib/arm-linux-gnueabihf/bak

gl2gears then runs with 50 FPS
And after I resized the window suddenly with 60, also sometimes the cpu usage is at ~5% then it jumps to 50%.


edit:
after a reboot it's now running with ~150 FPS!?
« Last Edit: June 04, 2014, 10:28:54 AM by Metanurb »

onefang

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
Re: Lime - es2gears libEGL warning: DRI2: failed to open lima
« Reply #4 on: July 27, 2014, 11:45:21 PM »
I'm having the same problem on an A20 board.  Using the sunxi-mali drivers didn't help.  Is there a particular revision or branch you used?  Any other clues?