A10 LIME Kernel Build

Started by wolo2663, February 15, 2014, 07:59:26 pm

Previous topic - Next topic

wolo2663

Hi,
I'm trying to build my own A10 Kernel and I get the following error:

apt-get install gcc-4.7-arm-linux-gnueabihf

E: Unable to locate package gcc-4.7-arm-linux-gnueabihf
E: Couldn't find any package by regex 'gcc-4.7-arm-linux-gnueabihf'

I have the following entry in my sources.list
deb http://www.emdebian.org/debian squeeze main

Does anyone know how to fix this?

Thanks,
Will

Robert Leacroft

I seem to remember that you first need to

apt-get install emdebian-archive-keyring

before it will find the package  but I might be confusing myself, and now you.

Robert

wolo2663

I tried that, but I still get the same error as before.

visionimpaired

Hi I have the same problem
I am really new to Linux and would like to try to build this, can someone please help?
Is there a really basic image prebuilt that only has the command line interface that I can download and load whatever I want through apt-get?
I downloaded v2 of the image and I notice using ps that there are many processes (that I don't need) especially I see sleep 1 appear many times. Can anyone advise why this is?
Thanks from a newbie.
V.

enz

I had the same problem.

due to this link:
http://linux-sunxi.org/Toolchain
you have to add the following repo to your sources.list (if you are developing on debian):
deb http://www.emdebian.org/debian/ unstable main

That worked for me, after i also installed the emdebian-archive-keyring

Hope this helps.

Martin

charlieholimex

Adding deb http://www.emdebian.org/debian/ unstable main to sources.list doesn't work for me.

None of the embedian sources seem to work.

W: Failed to fetch http://www.emdebian.org/debian/dists/unstable/Release  Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

kermit80


if you are on Ubuntu, to get the toolchain just run:

apt-get install gcc-arm-linux-gnueabihf

mrroland

If you have a board, and you are a litle patient,
You can compile the kernel on the board.
No need for cross compiling than. Also no need for emdebian.
I do this and have no problems at all.
Ik Just takes a few hours to compile.

MBR

Quote from: mrroland on June 13, 2014, 12:35:35 am
Ik Just takes a few hours to compile.


It may take hours, but unless you want to plug-in every USB device supported by Linux, support all filesystems, network protocol and such as the distribution kernels, you can prune the config and get rid of drivers for devices you don't have and featutres you don't need. The compile time of a minimalistic kernel should be a few tens of minutes, not hours.