Welcome, Guest

Author Topic: PIC_MAXI_WEB with MPLABX in MAC OSX  (Read 2162 times)

jlm7860

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
PIC_MAXI_WEB with MPLABX in MAC OSX
« on: February 08, 2014, 01:09:42 PM »
Hello,

I want to buy a PIC-MAXI-WEB after confirming the proper operation of my development tools that are
1) MPLABX IDE v2.00 in MAC OSX v10.6.8
2) XC8 v1.30 or v1.21 XC8

If I use the demo file PIC_MAXI_WEB_5_42 or 5_31 compiling the project stops with error (see attachment)
I think the problem is MPLABX for the same project compiles fine on an old XP PC with MPLAB IDE v8.76

-----------------------------------------------------------
make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
make[1]: Entering directory `/Users/jlm/MPLABXProjects/PIC-MAXI-WEB_5_42/PIC-MAXI-WEB_5_42/TCPIP/Demo App/PIC-MAXI-WEB_5_42.X'
make  -f nbproject/Makefile-default.mk dist/default/production/PIC-MAXI-WEB_5_42.X.production.hex
make[2]: Entering directory `/Users/jlm/MPLABXProjects/PIC-MAXI-WEB_5_42/PIC-MAXI-WEB_5_42/TCPIP/Demo App/PIC-MAXI-WEB_5_42.X'
"/Applications/microchip/xc8/v1.30/bin/xc8" --pass1  --chip=18F97J60 -Q -G  --double=24 --float=24 --emi=wordwrite --opt=default,+asm,+asmfile,-speed,+space,-debug --addrqual=ignore --mode=free -P -N255 --warn=0 --asmlist --summary=default,-psect,-class,+mem,-hex,-file --output=default,-inhx032 --runtime=default,+clear,+init,-keep,-no_startup,-download,+config,+clib,+plib --output=-mcof,+elf --stack=compiled "--errformat=%f:%l: error: (%n) %s" "--warnformat=%f:%l: warning: (%n) %s" "--msgformat=%f:%l: advisory: (%n) %s"    -obuild/default/production/_ext/1954962658/Announce.p1  "../../../Microchip/TCPIP Stack/Announce.c"
(908) exit status = 1
make[2]: *** [build/default/production/_ext/1954962658/Announce.p1] Error 1
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2
../../../Microchip/TCPIP Stack/Announce.c:61: error: (141) can't open include file "TCPIPConfig.h": No such file or directory
make[2]: Leaving directory `/Users/jlm/MPLABXProjects/PIC-MAXI-WEB_5_42/PIC-MAXI-WEB_5_42/TCPIP/Demo App/PIC-MAXI-WEB_5_42.X'
make[1]: Leaving directory `/Users/jlm/MPLABXProjects/PIC-MAXI-WEB_5_42/PIC-MAXI-WEB_5_42/TCPIP/Demo App/PIC-MAXI-WEB_5_42.X'

BUILD FAILED (exit value 2, total time: 117ms)

-----------------------------------------------------------

Can you help me solve this problem?

Thank you in advance,
« Last Edit: February 08, 2014, 11:30:56 PM by jlm7860 »

jlm7860

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: PIC_MAXI_WEB with MPLABX in MAC OSX
« Reply #1 on: February 09, 2014, 04:07:54 PM »
Hello,

My problem is solved by setting in MPLABX the "preprocessor macro definitions" and "include directories"
using the Microchip C18 compiler v3.40

cordially
« Last Edit: February 09, 2014, 04:13:07 PM by jlm7860 »