Disabling UART1 console output on A13 MICRO

Started by dlphnkng, August 27, 2013, 08:48:09 PM

Previous topic - Next topic


Hi all!

I'm trying to disable the console/debug output to the /dev/ttyS0 (UART1) on the Olinuxino A13 MICRO board, with the official Debian image. I've commented out the getty line in /etc/inittab, which successfully disabled the virtual terminal that appears after boot.
I also modified the script_GPIO_LCD_800x480.fex  and removed the section
uart_debug_port = 1
uart_debug_tx = port:PG03<4><1><default><default>
uart_debug_rx = port:PG04<4><1><default><default>
as per advice found somewhere around this forum, and compiled it with fex2bin, but it still outputs messages during boot-up and shutdown.

There is an entry in plaintext console = /dev/ttyS0 in the othervise binary file boot.scr. I naively tried to change it to console = , but it didn't work. I then found instructions here https://github.com/linux-sunxi/u-boot-sunxi/wiki and made a new boot.scr file from this source:
setenv bootargs console= root=/dev/mmcblk0p2 rootwait panic=10 ${extra}
ext2load mmc 0 0x43000000 boot/script.bin
ext2load mmc 0 0x48000000 boot/uImage
bootm 0x48000000
But there is still output during boot.

What am I missing? Thank you for any advice!


I have the same problem.
Tried to modify or remove the [uart_para] section in the script.bin but it didn't work.
So I tried this boot.scr:

setenv bootargs console=tty1 root=/dev/mmcblk0p2 rootwait panic=10 ${extra}
fatload mmc 0 0x43000000 script.bin
fatload mmc 0 0x48000000 uImage
watchdog 0
bootm 0x48000000

it disables the debug console from ttyS0 ( so I have no interferences running my application that uses ttyS0 ).
Nonetheless at startup some strings are sent to ttyS0 and some are sent to lcd ( which is quite annoying ).

P.S. I tried modifying the console option with console=tty2, console=ttyS1, console= ... or adding the quiet option to no avail
P.P.S. this is the compiled boot.scr ( need to be copied on the first partition of the sd )
P.P.P.S. another thing to do is to disables all serial login ( for example in /etc/inittab )


An addition ( it has already been pointed out in this forum ):
- needed to add a pullup ( 10K ) on UART1 Rx pin to prevent bootup lock


HI dlphnkng,

I have the same problem as you have mentioned.
Have you solved this problem?
Even i want to disable console booting on UART1 ttyS0 cause i need to use this UART1 for my other device for serial communication.
I have followed the steps you have mentioned and getting the half of the booting sequences on UART1 and the other half on LCD Screen.
I have A13 WIFI board with me.
Have done googled alot but not getting the proper way to solve my problem.
Any help will be greatly appreciated.


I wouldn't advise you to change the script.bin, because I think its not needed, and you could after all use UART1 for some peripheral instead of the console.

To remove the console output, you have to modify the kernel startup command line and remove all references to console.
This could in theory be done from command-line in u-boot. Unfortunately none of the many versions of u-boot I tested allows saving the environment on a13. The only solution is to compile your on u-boot and change the default kernel startup string (that's what I did).
For a one time tests, you can stop u-boot at startup and set a kernel startup string. Of course, on next reboot it will be lost...