EEG-SMT - do not getting any data at all

Started by flixe, November 07, 2013, 10:44:29 pm

Previous topic - Next topic

flixe

Hello,

I bought the EEG-SMT with 4 AE and 1 PE and got it with the fastest delivery I have ever seen the next day in Germany.

But sadly, I now have problems to get it to work. I have a Windows 8.1 64 bit. This is what I did:

1. I plugged the box in the USB-Port and directed the device installation to the extracted files of http://www.ftdichip.com/Drivers/CDM/CDM%20v2.08.30%20for%20Windows%208.1.zip

This worked well and the box has the red light.

It is now on port COM3 and I adjusted the connection settings to 57600 bits per second (9600 did not work either) and the latency to 2ms.

2. I plugged the passive electrode in DLR and hold it in the hand (with thumb), plugged 1 active in CH1+ and 1 active in CH1- that I pressed on my forehead.

3. I started all three programs (ElecGuru, BrainBay and Vibe...) like it is described in the manual. I paid attention to choose the right COM interface, pressed "play", but nothing happens.

In VibeServer it says "Connect!Ready... 0 hosts connected...".

And when trying to display in VibeDesigner (with the example of the manual), it says:

[WARNING] At time 0.078 sec <Box algorithm::Acquisition client> Could not receive memory buffer size
[WARNING] Box algorithm <Acquisition client> has been deactivated because process phase returned bad status

I also tried rebooting, deinstalling the driver an reinstalling it, tried a VM (Oracle Virtualbox) with a WinXP ... nothing happens. Not a single data peak.

What can I do?

LubOlimex

Hey flixe,

It seems you are doing everything correct. I recommend you to test only with Electric Guru until you get it going - the reason is that it is simplest and it would exclude software configuration problems.  Is it possible to describe exactly the result you are receiving in Electric Guru upon execution (pressing the "traffic light" symbol, having the electrodes placed)? Is it a flat line or noise? Maybe provide me with a screenshot.

Some tests you might try:

Try changing the COM port to 2 or 4.

Make sure you test both channels - the passive electrode plugged in DRL (hold it firmly in hand while testing to be sure it makes a good contact); then plug two of the active electrodes to channel 1 and test; then cycle the same electrodes to channel two and test again. Then change the two active electrodes and test both channels again.

Does the EEG entry in "Windows Device Manager" seem fine? No warnings, no problems detected - drivers seem ok? Sometimes there is such a problem with the unsigned drivers under Windows 8: http://www.craftedge.com/tutorials/driver_install_windows8/driver_install_win8.html.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

LubOlimex

Hey,

It seems that a number of EEG-SMT boards are affected by the problem described here: https://www.olimex.com/forum/index.php?topic=2031.0.

Please use these drivers (newer ones will not work): https://www.olimex.com/Products/_resources/FTDI_drivers_2.04.06.zip

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

flixe

That`s it! With the proposed driver I am getting signals from the box.

Please let me know per E-Mail or post in this forum if/when newer drivers will work.