Duinomite Mega with MOD-BT Not Discoverable

Started by lopezjm2001, April 18, 2013, 02:11:10 PM

Previous topic - Next topic


I have ordered and received a MOD-BT (Uext bluetooth device) to use with my Duinomite Mega from Dontronics. I run the following basic program below and it seems to work but my MOD-BT is not being discovered. I only see the LED on for a second when I plug in me MOD-BT but at no other time does the LED light up. Does the LED of the MOD-BT suppose to light up at any other time other than when being powered up?

The following example code sets up the MOD-BT as a serial SPP Bluetooth profile device via a Serial
115200 bps link between DuinoMite and another Bluetooth enabled device e.g. a computer or even a
mobile phone.
10 OPEN "COM3:115200" AS #1
30 PRINT #1, "AT+BTAUT=1,0": PAUSE 250 'set auto connect mode
40 PRINT #1, "AT+BTSRV=1" : PAUSE 250 'start SPP service now
41 'other devices can
42 'discover MOD-BT as
43 '"BGB203-1SPP" bluetooth
44 'device and pair with it
50 CLOSE #1 'now MOD-BT make serial
51 'bridge to COM3:
60 OPEN "COM3:115200" AS CONSOLE 'lets use this serial
65 'bridge as console then
After this code is executed you can pair to BGB203-1SPP with any bluetooth device and work with
DuinoMite in console mode.

When I run the above basic code the MOD-BT cannot be discovered by either my lap-top computer using windows7 or Ipad1 which have discovered each other but not my MOD-BT. I did a google search and I found this


The MOD_BT PCB is dated 2009 which is three years before the connection fix was discovered on september 2012 which means I may need to do the MOD-BT_DUINOMITE_connection fix.
Anyhow I have followed the connection fix several times by shorting out pin 2 and 7 on the Uext, reconfigure MOD-BT and flash the change to the MOD-BT etc. But still the MOD-BT cannot be discovered.

Anyhow I was hoping that maybe someone on this forum has some experience using a MOD-BT with a Duinomite Mega and have some tips for me.

I am thinking that maybe I received a dud MOD-BT.

Thanks in advance

John Lopez


Hello John,

I have the same problem, but also found the cause of the problem. I don't know if there was an older version of the Duinomite Mega when the fix was written, but the pinning is absolutely wrong.
The CTS line of the serial port is not on PIN 7 of the UEXT connector, but on PIN 9. So in BASIC it is not PIN(9), which has to be set to 0, but PIN(10).
I have it working now without SD card and with a real shortcut between PIN 9 and PIN 2 on the UEXT connector. I can use SENA BTERM on my Android phone as a terminal on the device.
However it is not stable; sometimes it works; sometimes not. It does not work together with the SD card. So I think I will see if I can use one of the other serial ports to communicate on.
If it is running it is a very nice feature to replace your standard USB terminal by the Android phone.


I have to correct my last message a little bit, but I think I have a stable solution now for the combination of the Duinomite with the BlueTooth UEXT module.

Two Handshake signals of the BT module have influence on the Duinomite pinning on the UEXT connector. It is the CTS on pin 7, but also the DSR on pin 9. With the command "AT+BTURT=115200,8,0,1,0" you can disable those handshake signals, but this does not cure the problem. The BT module is working if DSR and CTS are connected to ground, but then you cannot use the SD card.

If DSR and CTS are connected to the UEXT pins on the Duinomite with an SD card in it, the BlueTooth Console cannot be connected by another BlueTooth device.

I have made some hardware modifications to the BT module. I cut the the connection of pin 7 and pin 9 on the BT module near the UEXT connector and connected the other sides of the wires to ground. So now the CTS and DSR of the BT module are really connected to ground and the SD card signals have no influence on the module anymore. If someone likes to see how it is done, I can send a picture.