Welcome, Guest

Author Topic: Rolling AVR-ISP-MKII firmware from avrdude back to atmel studio troubles  (Read 5369 times)

makarenya

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
I bought AVR-ISP-MKII, and it worked perfectly in atmel studio 6.1.
Then i changed firmware to avrdude, removed the old driver and setted up new one (it's not a simple on win8 x64, but possible). Device still worked perfectly.
Next, i rolls back firmware to Atmel Studio, removed old driver, sets up atmel one. And have a trouble.
Device recognized in atmel studio, device can operate this mcu's, it can read and write fuses, it can write and read EEPORM, it can read flash (but very slow).
But, when i try to programm flash, Atmel Studio show this:
olimex ispProgramMem: Error status received: Got 0x81, expected 0x00

I try 3 different mcu's, and i got same error on every one.

When i secondary sets up avrdude firmware, it works perfect again. In avrdude, but not in Atmel Studio

I use firmware from this link: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/AVR-ISP-MK2-Firmware-WindowsDrivers.zip
« Last Edit: August 25, 2013, 08:39:55 PM by makarenya »

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1819
  • Karma: +46/-2
Re: Rolling AVR-ISP-MKII firmware from avrdude back to atmel studio troubles
« Reply #1 on: September 04, 2013, 10:16:33 AM »
Hello makarenya,

I suppose the Atmel Flip programming of AVR-ISP-MKII with the proper hex (AVR456-studio-AVRISP-MKII.hex) goes ok.

Then the only thing that might be causing problems are the drivers. Make sure you have COMPLETELY wiped the drivers (in "Windows Device Manager") associated with the device and then install the Atmel Studio drivers (AVR Jungo drivers). Those are typically located in : C:\Program Files (x86)\Atmel\AVR Tools folder.

Note that last week we released new drivers that work with Atmel Studio 6.1 and 6.2 so I recommend you to download them again.

Best regards,
Lub/OLIMEX

Technical support and documentation manager at Olimex