X11 Forwarding

Started by Robert Leacroft, July 29, 2013, 09:59:46 PM

Previous topic - Next topic

Robert Leacroft

Hi,  I cannot access the A10S (Debian on SD card) with X11 forwarding from an XP PC.  The same PC can happily access Raspberry Pi, Cudieboard (A10) and BBB (yes I have tried them all before settling on Olimex) with X11 forwarding   but the A10S just reports   "Can't open display" when I try Xlogo or anything else with Putty and Xming.  Normal Putty SSH is fine.   

The sshd_config  files in the A10 and A10S appear identical with X11 Forwarding set to Yes. Xauth all installed. I am running out of things to check;  does anyone have any ideas please or has anyone else got X11 forwarding already working? Is something missing from the Debian image?



Hi did you figure out what was wrong as i have just began playing about with my A10
also running the default debian image.
Presently trying to get the hdmi screen correct with my monitor ( TV with hdmi ) good picture but irritating overscan.
Using the debug serial port i can login and do some things but terminal does not work well. but that might be gtkterm into a usb-serial chip.
login in over the network can edit files fine as the term works correctly.
but i am used to being able to just do ->ssh -X2 some-machine<- and being able to run X programs.
But have not yet sussed the cant open display problem yet.

Robert Leacroft

Hi Span,

I tracked it down to the fact that the local loopback port on the Olimex was disabled by default in the Debian image (just like ETH0 see another thread). I added (or uncommented) the lines

auto lo
iface lo inet loopback

in the   /etc/network/interfaces      file  and it all started to work. I had read about needing local loopback for X11 but had understood  this as being needed on the client end and not the server end. Every other board I had ever used already had local loopback enabled by default hence all others worked OK.