Security fuse blown after programming MSP430-CCRF with demo for radio

Started by Sean87, July 12, 2013, 04:07:25 pm

Previous topic - Next topic

Sean87

Hi all,

I just received 2x MSP430-CCRF dev boards and I am using MSP-FET430UIF debugger.

I first tested the board with blink by RTC and it worked fine. next I tried to program the baord with "RF Connection_press BUT" demo that I downloaded from Olimex website. The program seemed to get uploaded and I entered debug mode. then I tried to program it again on the same board, but this time I got this error and can not program the chip anymore.

Fri Jul 12, 2013 15:02:43: Using license: Standalone license - IAR Embedded Workbench for Texas Instruments MSP430, 4K KickStart Edition 5.52
Fri Jul 12, 2013 15:02:43: Firmware version 30300006
Fri Jul 12, 2013 15:02:43: Interface dll version 3.3.0.6
Fri Jul 12, 2013 15:02:46: Security Fuse has been blow
Fri Jul 12, 2013 15:02:47: Fatal error: Could not find device (or device not supported)   Session aborted!


I did some search and some say that this doesn't mean that the fuse is 100% blown. It might be a problem in the code that resets the chip so the debugger can not attach itself to the chip. some suggest that erasing BSL would help. But I do not know how to erase BSL and upload new BSL.

Would you kindly tell me what should I do?