Welcome, Guest

Author Topic: Updating Uboot  (Read 10219 times)

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Updating Uboot
« on: October 12, 2012, 02:51:13 PM »
Have been playing with the A13 for a week now and i must say i'm impressed,

but i got a question regarding the updating process of u-boot as described by hehopmajieh here: https://github.com/hehopmajieh/olinuxino-a13/blob/master/README.md since i try to get debian to work on it.

My A13 seems to be hanging after/while i flash the IMG to it, I'm running every commando with SUDO under a virtual Ubuntu.  Here is screenshot where i think it hangs, even after 15min it doesn't change.



does it have something to do with that i still have my serial-to-usb connected or my USB mouse/keyboard??

any help would be greatly appreciated :)

olimex

  • Administrator
  • Hero Member
  • *****
  • Posts: 815
  • Karma: +22/-3
Re: Updating Uboot
« Reply #1 on: October 12, 2012, 04:50:29 PM »
I blogged today step by step how to make SD card with uboot and debian, maybe this will help? http://olimex.wordpress.com/2012/10/12/building-bootable-sd-card-with-debian-linux-image-for-a13-olinuxino/

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #2 on: October 12, 2012, 10:08:34 PM »
going to try that out, looks like a easier way to get debian to work :)

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #3 on: October 13, 2012, 12:09:00 AM »
trying to follow the step by step but i'm getting a command not found when i try to make the Uboot, it says:
Code: [Select]
/bin/bash: arm-linux-gnueabi-gcc: command not foundand
Code: [Select]
dirname: missing argument


when i try to compile the uImage for the kernel i get a somewhat familiar one:
Code: [Select]
make: arm-linux-gnueabi-gcc: command not found
CHK include/linux/version.h
CHK include/generated/utsrelease.h
make[1]: 'include/generated/mach-types.h' is updated
CC kernel/bounds.s
/bin/sh: 1: arm-linux-gnueabi-gcc: not found
make[1]: *** [kernel/bounds.s] error 127
make: *** [prepare0] error 2


has this anything to do with my PATH file that i need to add a new location? any help would be greatly appreciated :)
« Last Edit: October 13, 2012, 12:16:36 AM by TranceTrouble »

dr.bing

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Updating Uboot
« Reply #4 on: October 13, 2012, 12:31:23 AM »
trying to follow the step by step but i'm getting a command not found when i try to make the Uboot, it says:
Code: [Select]
/bin/bash: arm-linux-gnueabi-gcc: command not foundand
Code: [Select]
dirname: missing argument


when i try to compile the uImage for the kernel i get a somewhat familiar one:
Code: [Select]
make: arm-linux-gnueabi-gcc: command not found
CHK include/linux/version.h
CHK include/generated/utsrelease.h
make[1]: 'include/generated/mach-types.h' is updated
CC kernel/bounds.s
/bin/sh: 1: arm-linux-gnueabi-gcc: not found
make[1]: *** [kernel/bounds.s] error 127
make: *** [prepare0] error 2


has this anything to do with my PATH file that i need to add a new location? any help would be greatly appreciated :)

Make a symlink!

Code: [Select]
ln -s /usr/bin/arm-linux-gnueabi-gcc-4.6 /usr/bin/arm-linux-gnueabi-gcc

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #5 on: October 13, 2012, 01:02:14 AM »
Make a symlink!

Code: [Select]
ln -s /usr/bin/arm-linux-gnueabi-gcc-4.6 /usr/bin/arm-linux-gnueabi-gcc
awesome that worked thanks  :D

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #6 on: October 15, 2012, 04:15:29 PM »
hmm seems i'm stuck again, compiled everything successful to the uSD card and with some good hope i plugged it in, it runs my compiled u-boot and it detects my uImage and script.bin but when it tries to start the kernel it is giving a Starting Kernel message and continues to do nothing.

something i found, is when i go into the uboot i see that the uEnv.txt and boot.src are not found are these essential for the kernel? if so where do i get the correct uEnv.txt and boot.src they seem to be missing from the sdcard ?
« Last Edit: October 15, 2012, 04:17:27 PM by TranceTrouble »

dr.bing

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Updating Uboot
« Reply #7 on: October 15, 2012, 05:02:58 PM »
check your Kernel config!

our use this http://www.seacolors.de/A13/.config   ;)

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #8 on: October 15, 2012, 06:37:34 PM »
check your Kernel config!

our use this http://www.seacolors.de/A13/.config   ;)
going to check that out thanks :)

TranceTrouble

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: Updating Uboot
« Reply #9 on: October 15, 2012, 08:37:35 PM »
check your Kernel config!

our use this http://www.seacolors.de/A13/.config   ;)
going to check that out thanks :)

ah great i put it in the right directory compiled and got debian running now ;D
wonder what was going on earlier since i used all the standard values from the menuconfig.  ???