October 18, 2021, 08:34:17 am

Problem with ARM-USB-TINY-H

Started by mpassern, June 03, 2013, 04:58:16 pm

Previous topic - Next topic

mpassern

Hello,

I am using an ARM-USB-TINY-H JTAG to power & program a stm32-e407 board. Using openOCD and some sample cfg files all worked fine until today. After switching demo code from blinking led to chibios+lwip the JTAG's LED seems to be weaker and the connection with openOCD (same config) is not working any more:

Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: stm32f4x.cpu: IR capture error; saw 0x0f not 0x01

After an openOCD run the JTAG's LED is switched off. The Board's Power LED ist still working.

Any ideas why it is not working anymore?




LubOlimex

June 04, 2013, 09:15:26 am #1 Last Edit: June 04, 2013, 11:02:12 am by LubOlimex
Hello mpassern,

There might be various things that cause the issue but I believe it is one of these 3:

1. The last program you uploaded somehow corrupted the JTAG interface lines, this can be solved either by changing the reset strategy or setting the jumpers on the board to boot from another place, not the flash - check the table printed on the board. If you manage to restore the connection make sure to write another image that was working before.
2. You misconfigured jumpers located on the board. Make sure all jumpers are in default positions as described in the user's manual.
3. Hardware fault.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex