Olinuxino-micro USB ethernet adapter support

Started by tERBO, September 15, 2012, 03:00:03 PM

Previous topic - Next topic


The biggest disadvantage of Olinuxino-micro is that there is no network interface on board. And you can't use any USB wired network adapter because there is no drivers for that in any distro.

Someone on yahoo group uploaded a kernel patch for Archlinux that adds Davicom chip drivers, but those drivers was very unstable.

Does anyone managed to solve that problem?


I think all these problems will be solved when the new kernel 3.6 support is complete
until then there is no easy way to do it


Hi everyone
I'm quite new to Linux (I use it to run DHCP and some scripting servers etc) and I found it really frustrating trying to get the basics working on olinuxino-micro. Without Ethernet connectivity there is very little one can do with the board.  Also without basic compilation tools, chances of generating a working driver for any of the USB adapters are slim.

The team should focus on getting an image available, one that has support for some of the popular 801.11n USB modules that you can buy on ebay for a couple of dollars. This would create a great starting platform for all users on olinuxino-micro.

I've had my hopes to use the module for upcoming automation project but after 2 weeks of non-stop experiments had to give up, as I was not getting anywhere. Even the recently posted ArchLinux image had issues and kept crashing every 5 min - so compiling a driver failed due to os crash.
I hope with the new kernel some of those issues will go away and this fantastic product will be a big hit like the raspberry pi :)
Keep up the good work team!


I just build a 2.6 kernel (arch) adding the asix usb 10/100 networking driver. Works fine with ax88772 dongle I bought on amazon. I also added pl2303 and ftdi serial.  I am still have I2C read problems.  I am using a OpenRD box to build since it is the same ARM core.


If you have a reliably working kernel with any (inexpensive) wired or wireless ethernet device, I think a number of people would like to try it out!  I have an Olinuxino-Micro and I am waiting for this, after trying and failing for a few weeks.

Previously there was an Arch-Linux 2.6 kernel that *appeared* to work with DM9601 USB-LAN and Ralink RT5370 Wifi adaptors, but it showed regular errors in dmesg during network use, and it would eventually crash after about 24 hours or so of use.  That version was  2.6.35-5-ARCH+ #1 PREEMPT Tue Jul 31 21:03:21 CEST 2012 armv5tejl GNU/Linux   ...see for example, http://tech.groups.yahoo.com/group/olinuxino/message/1373

It was my understanding that kernel 2.6.xx has problems on the Olinuxino-Micro with any ethernet/wifi device, but I'd be happy to be proved wrong about that.  How long have you had it running, and how much file transfer have you done?


Well I am using the MAXI which seems to work well with the built in ethernet. I needed a second ethernet so I built the module for AX88772 from the archlinuxarm.com release.  I also build the realtek driver for the rt8192cu as described on this site and it seems to work.  No extensive testing but no errors while I was using.  I did see a lot of kernel messages regarding USB. I also build these for my OpenRD box which uses 3.1 and all seems to work.


I am running ARCH on several Micro and Maxi boards with some *old* RTL8187 based usb wifi adapters.
I could not unfortunately get an ASUS N10 (RTL8188 based) working.

To get the necessary packages installed I put the microSD card in the Maxi first, and used ethernet to download and install the necessary components.  I then moved the card to the Micro board.

To get WiFi working on an RTL8187 run:
pacman -S wireless_tools
pacman -S wpa_supplicant

Then edit
/etc/rc.conf - to configure wlan0 instead of usb0 (I use static IP currently, but DHCP should be OK)
/etc/wpa_supplicant/wpa_supplicant.conf - to add your WiFi SSID & passphrase
/etc/rc.local - to start wpa_supplicant for interface wlan0
/etc/resolv.conf - to add a nameserver (if using static IP)

I've got more USB WiFi adapters on the way, and will report back on any additional ones that I find work.




Where can we buy a usb-ethernet adaptator "plug&play" in europe for olinuxino-micro ?
Without install driver manualy on imx233.



I am having pretty good success with the Belkin F4U047 adapter (aka F4U061 - here is a US store). I had to recompile kernel with "CONFIG_USB_NET_AX8817X=y" but then it worked with no problem. It does occasionally drop the link for a second, and I haven't tested it under heavy traffic, but it does what I need to as far as transferring new app files for testing during development. (It's not the best option I'm sure - it was just what I had laying around the office or could get on short notice.)


Quote from: andersop on September 25, 2012, 12:24:29 AM
... It does occasionally drop the link for a second...

Yes, that's what happened with my experiments a few months ago also. I suspect you may find some network-related errors in dmesg and if you keep using your network regularly, I think it will likely crash sooner or later.