SPI on latest archlinux (3.7.2-2-ARCH)

Started by encryped, April 24, 2013, 03:21:48 pm

Previous topic - Next topic

encryped

April 24, 2013, 03:21:48 pm Last Edit: April 24, 2013, 04:56:42 pm by encryped
Hello, I have an olinuxino micro with latest archlinux installed, kernel 3.7.2-2-ARCH.
I would to get SPI working on this board (user mode)
When i type ls /dev/ i get this:
autofs           loop2               ptmx    tty15  tty32  tty5   ttyAMA0
block            loop3               pts     tty16  tty33  tty50  ttyAPP0
btrfs-control    loop4               random  tty17  tty34  tty51  urandom
bus              loop5               rtc     tty18  tty35  tty52  vcs
char             loop6               rtc0    tty19  tty36  tty53  vcs1
console          loop7               shm     tty2   tty37  tty54  vcs2
core             loop-control        snd     tty20  tty38  tty55  vcs3
cpu_dma_latency  mapper              stderr  tty21  tty39  tty56  vcs4
disk             mem                 stdin   tty22  tty4   tty57  vcs5
fd               mmcblk0             stdout  tty23  tty40  tty58  vcs6
full             mmcblk0p1           tgt     tty24  tty41  tty59  vcsa
fuse             mmcblk0p2           tty     tty25  tty42  tty6   vcsa1
i2c-0            mmcblk0p3           tty0    tty26  tty43  tty60  vcsa2
initctl          mqueue              tty1    tty27  tty44  tty61  vcsa3
input            net                 tty10   tty28  tty45  tty62  vcsa4
kmsg             network_latency     tty11   tty29  tty46  tty63  vcsa5
log              network_throughput  tty12   tty3   tty47  tty7   vcsa6
loop0            null                tty13   tty30  tty48  tty8   zero
loop1            ppp                 tty14   tty31  tty49  tty9

When i look for the kernel modules i find these 2:
[root@olinuxino spi]# ls
spi-bitbang.ko.gz  spi-gpio.ko.gz

Do these modules work, and how do i have to load them ?

encryped

If i load spi-gpio.ko using insmod i get this
ERROR: could not insert module spi-gpio.ko: Unknown symbol in module
dmesg tells me this:
[  135.970000] spi_gpio: Unknown symbol spi_bitbang_cleanup (err 0)
[  135.970000] spi_gpio: Unknown symbol spi_bitbang_stop (err 0)
[  135.970000] spi_gpio: Unknown symbol spi_bitbang_setup_transfer (err 0)
[  135.970000] spi_gpio: Unknown symbol spi_bitbang_setup (err 0)
[  135.970000] spi_gpio: Unknown symbol spi_bitbang_start (err 0)

jeroends

hello,
look at the following topic: https://www.olimex.com/forum/index.php?topic=873.msg4561#msg4561

here you can find what to add in your dts file to enable userspace spi.