Internet radio with the micro?

Started by cv007, April 16, 2013, 05:53:49 PM

Previous topic - Next topic


I purchased the imx233 micro hoping to be able to simply stream a few internet radio stations (mp3 or aac). It has audio out and usb for a wifi dongle, so I think the hardware is certainly capable. I normally play around in the microcontroller playground, but by the time you cobble together wireless networking, dealing with codecs, etc., it seems like its not really the way to do it since a ~$30 Olimex board could do it easier/better/cheaper.

I have been playing around with linux off and on (various flavors) since Redhat 5.x (purchased in a box, no less), but I'm no Linux expert. I was able to download/extract/dd the latest arch image ( to a sd card, connect my usb-serial adapter, and have the micro boot up (big surprise, it worked). I have a couple usb wifi dongles that are Ralink types (3070 and 28xx I believe), but when plugged in, I just see a lot of 'phy' messages.

Question1: Am I right in thinking a simple internet radio stream using the audio out can be done?

Question2: Following the instructions at, will I be able to build a kernel with the Ralink drivers? (maybe they are already in the latest image I downloaded, don't know)- I did follow the instructions, and enabled the Ralink drivers in menuconfig, was able to get through the instructions ok, overwriting the first partition (using dd) to replace the kernel (I think that is what I was doing), but was unable to even test it, as my micro seemed to quit working (before I made this kernel change) (see question3)

Question3: my micro decided to quit working for some reason- power/micro/usb-serial/sd card working, then simply moved it to a different location and now it does not work- no serial output seen, no green light. With the power connected, I see 5v and 3.3v where they should be, usb-serial is working (simple loopback test to verify). Should there be any serial output even if an sd card is not mounted? (like error codes or something?) Are there any other signs of life I can look for?

I'll start over, create another sd card image like I originally did, and see if that works (while it worked, I should have tried powering up without sd card to see if there is any output when sd is missing or corrupt- would be nice to know now that it doesn't work)

If any one has any pointers on getting one of my ralink wifi dongles to work, and any input on whether an internet radio is feasible, I would appreciate it. (tips/pointers also accepted for getting my micro to work again)

Thank you.


No joy.

Created a new sd card from Archlinuxarm image. Power tests ok, 5v and 3.3v where they should be, boot pins test correct for default settings. (Nothing really changed when it went from working to not working, except it was unplugged then plugged in again).

Does anyone know if there should be ANY activity on the debug uart when powering up? (any messages go out the uart whether the boot media is working or not?)

Maybe I'll have to order another one, or try to find a RasPi board instead.

The user manual lists board revisions B,B1,B2,C but the Olimex hardware github only shows rev B schematics (I received a rev B board from Digikey, so maybe these are not flying off the shelves). Even though B.B1,B2 are essentially the same (not sure about C), does the lack of the schematics available for each revision indicate this board is pretty much history?


B1,B2,C are with very minor updates from B - mostly routing so do not worry you have working and up to date board :)

regarding adding new USB device driver in Linux (in your case Ralink) is not trivial task, the image in the wiki have support for AX88772B and RTL8188CU (wired/wifi) Ethernet devices we sell, they work for sure with imx233 image