Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A64 => Topic started by: mossroy on December 20, 2021, 03:34:57 pm

Title: Debian apt repositories
Post by: mossroy on December 20, 2021, 03:34:57 pm
In current bullseye image http://images.olimex.com/release/a64/A64-OLinuXino-bullseye-minimal-20211130-145129.img.7z , here is the content of /etc/apt/sources.list :

deb http://httpredir.debian.org/debian bullseye main contrib non-free
while, on a "regular" Debian system (installed with debian-installer), it is something like :

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main

deb http://security.debian.org/debian-security bullseye-security main
deb-src http://security.debian.org/debian-security bullseye-security main

# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://deb.debian.org/debian/ bullseye-updates main
deb-src http://deb.debian.org/debian/ bullseye-updates main

Is it on purpose that bullseye-security and bullseye-updates repositories have been removed?

Aren't we missing at least some security updates without them?
Title: Re: Debian apt repositories
Post by: Gaƫl on May 11, 2022, 02:07:33 pm
Indeed, when editing sources.list from :
deb http://httpredir.debian.org/debian bullseye main contrib non-free
to:
deb http://deb.debian.org/debian bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free

Some security updates are found :
$ apt list --upgradable
Listing... Done
gzip/stable-security 1.10-4+deb11u1 armhf [upgradable from: 1.10-4]
liblzma5/stable-security 5.2.5-2.1~deb11u1 armhf [upgradable from: 5.2.5-2]
libtiff5/stable-security 4.2.0-1+deb11u1 armhf [upgradable from: 4.2.0-1]
linux-libc-dev/stable-security 5.10.113-1 armhf [upgradable from: 5.10.106-1]
tzdata/stable-updates 2021a-1+deb11u3 all [upgradable from: 2021a-1+deb11u2]
xz-utils/stable-security 5.2.5-2.1~deb11u1 armhf [upgradable from: 5.2.5-2]
zlib1g-dev/stable-security 1:1.2.11.dfsg-2+deb11u1 armhf [upgradable from: 1:1.2.11.dfsg-2]
zlib1g/stable-security 1:1.2.11.dfsg-2+deb11u1 armhf [upgradable from: 1:1.2.11.dfsg-2]