Olimex Support Forum

Microcontrollers => MSP430 => Topic started by: DKTech on August 05, 2021, 04:53:07 am

Title: MSP430-JTAG-ISO-MK2 MPS430.dll not working with Code Composer
Post by: DKTech on August 05, 2021, 04:53:07 am
Can anyone provide some direction on getting the downloaded (2.007) drivers to work with the  MSP430-JTAG-ISO-MK2? These don't want to behave when trying to run debugger via Code Composer. I copied the .dll in the downloaded package 2.007 to the my CCS installed directory "C:\ti\ccs1031\ccs\ccs_base\DebugServer\drivers".
I get this windows error:
"Error initializing emulator:
Error loading C:\ti\ccs1031\ccs\ccs_base\DebugServer\drivers\msp430.dll: %1 is not a valid Win32 application."
I running on a 64bit system are there .dlls available for 64 bit installs?

I have Olimex MSP430 Programmer application working when I replaced the driver in that application folder, but I keep getting an error thrown when I try to initiate debugging via Code Composer.

I had disabled Enforcement of driver signatures to get the programmer drivers properly installed
Title: Re: MSP430-JTAG-ISO-MK2 MPS430.dll not working with Code Composer
Post by: DKTech on August 10, 2021, 09:06:14 am
Hello does anyone at Olimex support their products?? Or should I just buy a MSP-FET???
Title: Re: MSP430-JTAG-ISO-MK2 MPS430.dll not working with Code Composer
Post by: LubOlimex on August 16, 2021, 01:22:28 pm
What version of Code Composer Studio do you use?

Did you notice this part in the description:

(https://i.imgur.com/h4m412F.jpg)