Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A10 => Topic started by: Emill on June 03, 2021, 02:48:08 am

Title: Boot hangs during "Set USB Power ON"
Post by: Emill on June 03, 2021, 02:48:08 am
I just got my new A10-OLinuXino-LIME-n8GB. But no matter what image I write and put on my sandisk ultra microsdhc card 16 GB, it hangs during the boot, apparently when intializing USB.

I've tried http://images.olimex.com/release/a10/A10-OLinuXino-buster-base-20210513-112230.img.7z, http://images.olimex.com/release/a10/A10-OLinuXino-focal-base-20210513-112230.img.7z as well as openSUSE Leap 15.1 XFCE image (https://en.opensuse.org/HCL:A10-OLinuXino-LIME). They all fail in the same way while booting U-Boot. This is an output from the openSUSE image:

U-Boot SPL 2019.01 (Aug 21 2019 - 17:22:46 +0000)
DRAM: 512 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1U-Boot 2019.01 (Aug 21 2019 - 17:22:46 +0000) Allwinner TechnologyCPU:   Allwinner A10 (SUN4I)
Model: Olimex A10-OLinuXino-LIME
I2C:   ready
DRAM:  512 MiB
MMC:   mmc@1c0f000: 0
Loading Environment from FAT... *** Warning - bad CRC, using default environmentIn:    serial
Out:   serial
Err:   serial
Net:   eth0: ethernet@1c0b000
starting USB...
USB0: 

I also tried the older https://ftp.olimex.com/Lub-clients/a10_Lime_debian_3.4.90_release_3.img.7z image. I guess it doesn't initialize USB during U-Boot, so it instead hangs while Linux turns USB on:

U-Boot SPL 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55)
Board: A10-OLinuXino-Lime
DRAM: 512 MiB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
spl: not an uImage at 1600


U-Boot 2014.04-10675-g44b53fd (May 23 2014 - 13:02:55) Allwinner Technology

CPU:   Allwinner A10 (SUN4I)
Board: A10-OLinuXino-Lime
I2C:   ready
DRAM:  512 MiB
MMC:   SUNXI SD/MMC: 0
In:    serial
Out:   serial
Err:   serial
Net:   emac
Hit any key to stop autoboot:  0
reading uEnv.txt
104 bytes read in 17 ms (5.9 KiB/s)
Loaded environment from uEnv.txt
reading boot.scr
337 bytes read in 16 ms (20.5 KiB/s)
Jumping to boot.scr
## Executing script at 44000000
reading script.bin
54504 bytes read in 38 ms (1.4 MiB/s)
reading uImage
4447504 bytes read in 224 ms (18.9 MiB/s)
## Booting kernel from Legacy Image at 48000000 ...
   Image Name:   Linux-3.4.90+
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    4447440 Bytes = 4.2 MiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

<6>Booting Linux on physical CPU 0
<6>Initializing cgroup subsys cpuset
<5>Linux version 3.4.90+ (root@debian) (gcc version 4.7.1 (Debian 4.7.1-7) ) #3 PREEMPT Tue Jun 10 09:17:04 EEST 2014
CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: sun4i
<6>Memory Reserved:
<6>     SYS  : 0x43000000 - 0x4300ffff  (  64 kB)
<6>     VE   : 0x44000000 - 0x48ffffff  (  80 MB)
<6>     LCD  : 0x49000000 - 0x49ffffff  (  16 MB)
Memory policy: ECC disabled, Data cache writeback
<6>sunxi: Allwinner A10 revision C (AW1623/sun4i) detected.
<7>On node 0 totalpages: 131072
<7>free_area_init_node: node 0, pgdat c085f108, node_mem_map d0000000
<7>  DMA zone: 512 pages used for memmap
<7>  DMA zone: 0 pages reserved
<7>  DMA zone: 65024 pages, LIFO batch:15
<7>  Normal zone: 512 pages used for memmap
<7>  Normal zone: 65024 pages, LIFO batch:15
<7>pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768<c>
<7>pcpu-alloc: <c>[0] <c>0 <c>
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048
<5>Kernel command line: console=ttyS0,115200 hdmi.audio=EDID:0 disp.screen0_output_mode=1280x720p50 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 root=/dev/mmcblk0p2 rootwait panic=10
<6>PID hash table entries: 2048 (order: 1, 8192 bytes)
<6>Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
<6>Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
<6>Memory: 512MB = 512MB total
<5>Memory: 410988k/410988k available, 113300k reserved, 0K highmem
<5>Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
    vmalloc : 0xe0800000 - 0xff000000   ( 488 MB)
    lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)
    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
    modules : 0xbf000000 - 0xbfe00000   (  14 MB)
      .text : 0xc0008000 - 0xc07cbe24   (7952 kB)
      .init : 0xc07cc000 - 0xc07f7000   ( 172 kB)
      .data : 0xc07f8000 - 0xc086a720   ( 458 kB)
       .bss : 0xc086a744 - 0xc0a242a8   (1767 kB)
<6>SLUB: Genslabs=11, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
<6>NR_IRQS:128
<6>sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 178956ms
<6>Console: colour dummy device 80x30
<6>Calibrating delay loop... <c>1001.88 BogoMIPS (lpj=5009408)
<6>pid_max: default: 32768 minimum: 301
<6>Mount-cache hash table entries: 512
<6>Initializing cgroup subsys cpuacct
<6>Initializing cgroup subsys devices
<6>Initializing cgroup subsys freezer
<6>Initializing cgroup subsys blkio
<6>CPU: Testing write buffer coherency: ok
<6>hw perfevents: enabled with ARMv7 Cortex-A8 PMU driver, 5 counters available
<6>Setting up static identity map for 0x4055dc50 - 0x4055dca8
<6>devtmpfs: initialized
<6>dummy:
<6>NET: Registered protocol family 16
<6>DMA: preallocated 256 KiB pool for atomic coherent allocations
<6>hw-breakpoint: debug architecture 0x4 unsupported.
<6>Init eGon pin module V2.0
SOFTWINNER DMA Driver, (c) 2003-2004,2006 Simtec Electronics
<6>Initialize DMAC OK
<6>bio: create slab <bio-0> at 0
<5>SCSI subsystem initialized
<7>libata version 3.00 loaded.
<6>usbcore: registered new interface driver usbfs
<6>usbcore: registered new interface driver hub
<6>usbcore: registered new device driver usb
<6>Linux video capture interface: v2.00
<6>Advanced Linux Sound Architecture Driver Version 1.0.25.
<6>Bluetooth: Core ver 2.16
<6>NET: Registered protocol family 31
<6>Bluetooth: HCI device and connection manager initialized
<6>Bluetooth: HCI socket layer initialized
<6>Bluetooth: L2CAP socket layer initialized
<6>Bluetooth: SCO socket layer initialized
<6>Switching to clocksource aw_64bits_counter
<5>FS-Cache: Loaded
<6>cfg80211: Calling CRDA to update world regulatory domain
<6>CacheFiles: Loaded
[usb_manager]: CONFIG_USB_SW_SUNXI_USB0_OTG
[sw_hcd0]: usb host driver initialize........
[sw_hcd0]: open_usb_clock
[sw_hcd0]: host_init_state = 1
[sw_hcd0]: platform is usb host
[sw_hcd0]: sw_hcd_host0: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx (X), HB-ISO Tx (X), SoftConn)
[sw_hcd0]: sw_hcd_init_controller: sw_hcd_host0: USB Host mode controller at f1c13000 using PIO, IRQ 38
<6>sw_hcd_host0 sw_hcd_host0: sw_hcd host driver
<6>sw_hcd_host0 sw_hcd_host0: new USB bus registered, assigned bus number 1
<6>hub 1-0:1.0: USB hub found
<6>hub 1-0:1.0: 1 port detected
wrn: hcd is not enable, need not start hcd
[sw_hcd0]: sw_usb_host0_disable start
-------sw_hcd0_soft_disconnect---------
is_on = 0, hcd0_set_vbus_cnt = 0
[sw_hcd_host0]: Set USB Power Off
wrn: hcd is not enable, need not stop hcd
[sw_hcd0]: close_usb_clock
[sw_hcd0]: sw_usb_host0_disable end
[sw_udc]: udc_init: version 20080411
<6>NET: Registered protocol family 2
<6>IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
<6>TCP established hash table entries: 16384 (order: 5, 131072 bytes)
<6>TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
<6>TCP: Hash tables configured (established 16384 bind 16384)
<6>TCP: reno registered
<6>UDP hash table entries: 256 (order: 0, 4096 bytes)
<6>UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
<6>NET: Registered protocol family 1
<6>RPC: Registered named UNIX socket transport module.
<6>RPC: Registered udp transport module.
<6>RPC: Registered tcp transport module.
<6>RPC: Registered tcp NFSv4.1 backchannel transport module.
<6>audit: initializing netlink socket (disabled)
<5>type=2000 audit(0.359:1): initialized
<5>VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
<5>NFS: Registering the id_resolver key type
<6>NTFS driver 2.1.30 [Flags: R/W].
<6>fuse init (API version 7.18)
<6>msgmni has been set to 802
<3>alg: comp: Compression test 1 failed for lzo-generic: output len = 57
<6>alg: No test for stdrng (krng)
<6>Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
<6>io scheduler noop registered
<6>io scheduler deadline registered
<6>io scheduler cfq registered (default)
<6>sunxi disp driver loaded (/dev/disp api 1.0)
<6>Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled
<6>[uart]: used uart info.: 0x11
<6>[uart]: serial probe 0 irq 1 mapbase 0x01c28000
<6>sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 1) is a U6_16550A
[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Linux version 3.4.90+ (root@debian) (gcc version 4.7.1 (Debian 4.7.1-7) ) #3 PREEMPT Tue Jun 10 09:17:04 EEST 2014
[    0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine: sun4i
[    0.000000] Memory Reserved:
[    0.000000]  SYS  : 0x43000000 - 0x4300ffff  (  64 kB)
[    0.000000]  VE   : 0x44000000 - 0x48ffffff  (  80 MB)
[    0.000000]  LCD  : 0x49000000 - 0x49ffffff  (  16 MB)
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] sunxi: Allwinner A10 revision C (AW1623/sun4i) detected.
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048
[    0.000000] Kernel command line: console=ttyS0,115200 hdmi.audio=EDID:0 disp.screen0_output_mode=1280x720p50 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 root=/dev/mmcblk0p2 rootwait panic=10
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 512MB = 512MB total
[    0.000000] Memory: 410988k/410988k available, 113300k reserved, 0K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xe0800000 - 0xff000000   ( 488 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc07cbe24   (7952 kB)
[    0.000000]       .init : 0xc07cc000 - 0xc07f7000   ( 172 kB)
[    0.000000]       .data : 0xc07f8000 - 0xc086a720   ( 458 kB)
[    0.000000]        .bss : 0xc086a744 - 0xc0a242a8   (1767 kB)
[    0.000000] SLUB: Genslabs=11, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:128
[    0.000000] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 178956ms
[    0.000000] Console: colour dummy device 80x30
[    0.006000] Calibrating delay loop... 1001.88 BogoMIPS (lpj=5009408)
[    0.050261] pid_max: default: 32768 minimum: 301
[    0.053847] Mount-cache hash table entries: 512
[    0.057677] Initializing cgroup subsys cpuacct
[    0.061078] Initializing cgroup subsys devices
[    0.064474] Initializing cgroup subsys freezer
[    0.067717] Initializing cgroup subsys blkio
[    0.071257] CPU: Testing write buffer coherency: ok
[    0.078794] hw perfevents: enabled with ARMv7 Cortex-A8 PMU driver, 5 counters available
[    0.084336] Setting up static identity map for 0x4055dc50 - 0x4055dca8
[    0.087165] devtmpfs: initialized
[    0.089414] dummy:
[    0.092928] NET: Registered protocol family 16
[    0.099228] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.104544] hw-breakpoint: debug architecture 0x4 unsupported.
[    0.107984] Init eGon pin module V2.0
[    0.113394] SOFTWINNER DMA Driver, (c) 2003-2004,2006 Simtec Electronics
[    0.115459] Initialize DMAC OK
[    0.122685] bio: create slab <bio-0> at 0
[    0.125858] SCSI subsystem initialized
[    0.133406] usbcore: registered new interface driver usbfs
[    0.137718] usbcore: registered new interface driver hub
[    0.141830] usbcore: registered new device driver usb
[    0.145474] Linux video capture interface: v2.00
[    0.150973] Advanced Linux Sound Architecture Driver Version 1.0.25.
[    0.153814] Bluetooth: Core ver 2.16
[    0.157264] NET: Registered protocol family 31
[    0.162568] Bluetooth: HCI device and connection manager initialized
[    0.166399] Bluetooth: HCI socket layer initialized
[    0.170413] Bluetooth: L2CAP socket layer initialized
[    0.174253] Bluetooth: SCO socket layer initialized
[    0.178893] Switching to clocksource aw_64bits_counter
[    0.180851] FS-Cache: Loaded
[    0.186239] cfg80211: Calling CRDA to update world regulatory domain
[    0.188369] CacheFiles: Loaded
[    0.195133] [usb_manager]: CONFIG_USB_SW_SUNXI_USB0_OTG
[    0.198946] [sw_hcd0]: usb host driver initialize........
[    0.203135] [sw_hcd0]: open_usb_clock
[    0.227308] [sw_hcd0]: host_init_state = 1
[    0.228277] [sw_hcd0]: platform is usb host
[    0.231194] [sw_hcd0]: sw_hcd_host0: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx (X), HB-ISO Tx (X), SoftConn)
[    0.242364] [sw_hcd0]: sw_hcd_init_controller: sw_hcd_host0: USB Host mode controller at f1c13000 using PIO, IRQ 38
[    0.254899] sw_hcd_host0 sw_hcd_host0: sw_hcd host driver
[    0.261595] sw_hcd_host0 sw_hcd_host0: new USB bus registered, assigned bus number 1
[    0.264766] hub 1-0:1.0: USB hub found
[    0.267656] hub 1-0:1.0: 1 port detected
[    0.271498] wrn: hcd is not enable, need not start hcd
[    0.272738] [sw_hcd0]: sw_usb_host0_disable start
[    0.278746] -------sw_hcd0_soft_disconnect---------
[    0.281710] is_on = 0, hcd0_set_vbus_cnt = 0
[    0.284759] [sw_hcd_host0]: Set USB Power Off
[    0.288502] wrn: hcd is not enable, need not stop hcd
[    0.289516] [sw_hcd0]: close_usb_clock
[    0.292014] [sw_hcd0]: sw_usb_host0_disable end
[    0.295179] [sw_udc]: udc_init: version 20080411
[    0.301358] NET: Registered protocol family 2
[    0.307459] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.313935] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[    0.319653] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[    0.325265] TCP: Hash tables configured (established 16384 bind 16384)
[    0.327449] TCP: reno registered
[    0.332234] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.337476] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.340936] NET: Registered protocol family 1
[    0.346068] RPC: Registered named UNIX socket transport module.
[    0.349726] RPC: Registered udp transport module.
[    0.353428] RPC: Registered tcp transport module.
[    0.358817] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.363895] audit: initializing netlink socket (disabled)
[    0.367582] type=2000 audit(0.359:1): initialized
[    0.376987] VFS: Disk quotas dquot_6.5.2
[    0.382326] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.387950] NFS: Registering the id_resolver key type
[    0.392104] NTFS driver 2.1.30 [Flags: R/W].
[    0.395451] fuse init (API version 7.18)
[    0.398735] msgmni has been set to 802
[    0.408336] alg: comp: Compression test 1 failed for lzo-generic: output len = 57
[    0.411488] alg: No test for stdrng (krng)
[    0.418135] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.421017] io scheduler noop registered
[    0.424316] io scheduler deadline registered
[    0.427996] io scheduler cfq registered (default)
[    0.432573] sunxi disp driver loaded (/dev/disp api 1.0)
[    0.438067] Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled
[    0.442045] [uart]: used uart info.: 0x11
[    0.446624] [uart]: serial probe 0 irq 1 mapbase 0x01c28000
[    0.472611] sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 1) is a U6_16550A
<6>console [ttyS0] enabled
[    1.128249] console [ttyS0] enabled
<6>[uart]: serial probe 4 irq 17 mapbase 0x01c29000
[    1.136525] [uart]: serial probe 4 irq 17 mapbase 0x01c29000
<6>sunxi-uart.4: ttyS1 at MMIO 0x1c29000 (irq = 17) is a U6_16550A
[    1.168198] sunxi-uart.4: ttyS1 at MMIO 0x1c29000 (irq = 17) is a U6_16550A
<7>G2D: drv_g2d_init
<6>G2D: Module initialized.major:251
[    1.180840] G2D: Module initialized.major:251
<6>brd: module loaded
[    1.187769] brd: module loaded
<6>loop: module loaded
[    1.194991] loop: module loaded
[spi]: sw spi init !!
[    1.200369] [spi]: sw spi init !!
[spi]: Found 1 spi devices in config files
[    1.207554] [spi]: Found 1 spi devices in config files
[spi]: boards num modalias         max_spd_hz       bus_num  cs   mode
[    1.218953] [spi]: boards num modalias         max_spd_hz       bus_num  cs   mode
[spi]: spi_board0 irq gpio not used
[    1.229752] [spi]: spi_board0 irq gpio not used
[spi]: 0          spidev           10000000         2        0    0x3
[    1.240715] [spi]: 0          spidev           10000000         2        0    0x3
[spi]: bus num = 2, spi used = 1
[    1.251599] [spi]: bus num = 2, spi used = 1
[spi]: source = sdram_pll_p, src_clk = 480000000, mclk 96000000
[    1.261780] [spi]: source = sdram_pll_p, src_clk = 480000000, mclk 96000000
<6>sun4i-spi sun4i-spi.2: master is unqueued, this is deprecated
[    1.274595] sun4i-spi sun4i-spi.2: master is unqueued, this is deprecated
[spi]: allwinners SoC SPI Driver loaded for Bus SPI-2 with 2 Slaves attached
[    1.288335] [spi]: allwinners SoC SPI Driver loaded for Bus SPI-2 with 2 Slaves attached
[spi]: [spi-2]: driver probe succeed, base f1c17000, irq 12, dma_id 2!
[    1.302691] [spi]: [spi-2]: driver probe succeed, base f1c17000, irq 12, dma_id 2!
<6>sunxi_emac Using mii phy on PortA
[    1.313608] sunxi_emac Using mii phy on PortA
<6>sunxi_emac Using MAC from SID: 02:56:06:01:01:71[    1.332527] sunxi_emac Using MAC from SID: 02:56:06:01:01:71<6>PPP generic driver version 2.4.2

[    1.342991] PPP generic driver version 2.4.2
<6>PPP BSD Compression module registered
[    1.351217] PPP BSD Compression module registered
<6>PPP Deflate Compression module registered
[    1.359942] PPP Deflate Compression module registered
<6>PPP MPPE Compression module registered
[    1.369532] PPP MPPE Compression module registered
<6>NET: Registered protocol family 24
[    1.377796] NET: Registered protocol family 24
<6>ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.387753] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
<6>ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.399466] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[sw-ehci1]: open clock
[    1.407926] [sw-ehci1]: open clock
[sw-ehci1]: Set USB Power ON
[    1.433912] [sw-ehci1]: Set USB Power ON
<6>

Is there some hardware issue with my new board, or did I do something wrong?

Tried two different usb power adapters as well (one 5V 2.4A, one 5V 2A), and even powering it from my computer.
Title: Re: Boot hangs during "Set USB Power ON"
Post by: LubOlimex on June 03, 2021, 08:53:08 am
Almost certainly insufficient powering. You can't power the board from the USB connector, even if you use externally powered USB.

You need to apply 5V to the barrel power jack.
Title: Re: Boot hangs during "Set USB Power ON"
Post by: Emill on June 04, 2021, 10:18:30 pm
Thanks for the quick reply. Using an external power supply using the separate 5V jack worked totally fine!

I'm a bit surprised however that powering the board doesn't work correctly from the usb port at all. When reading the user manual, I got the impression that this would work fine unless you have power hungry peripherals. (Without anything at all connected to the board, it still fails to boot when powering from usb.) In particular, the manual says that it's ok if only hdmi is connected: "Note that when powering the board from the USB_OTG, the current provided might be insufficient to also power a bigger LCD connected to the LCD_con. However, this power option is capable of driving the board when using external display connected to the HDMI connector."

Anyway, thanks for your help as I can now use my board :)