Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A64 => Topic started by: afancher on February 19, 2021, 06:16:35 am

Title: Splash Screens on the A64...U-Boot, Plymouth?
Post by: afancher on February 19, 2021, 06:16:35 am
Hi, has anyone had any luck or experience with configuring a splash screen on a current or past Olimex Debian release on the Olinuxino-A64?

I am exploring the options of enabling it in U-Boot at the prompt, however bitmap support seems not to be enabled in the currently distributed U-boot configuration and I'm assuming requires a rebuilt u-boot binary.  I have tried adding the lines
setenv splashsource mmc_fs
setenv splashfile /boot/logo.bmp
setenv splashsource mmc_fs
to no avail in both the boot.cmd/scr and uEnv.txt files.  Additionally, I am unable to enter save these commands at the u-boot command prompt as the "savenv" command returns a response of  "Saving Environment to EXT4... Unsupported feature metadata_csum found, not writing. Unable to write "/uboot.env" from mmc0:1, Failed" (which is a side note that applies in general to writing any environment variables at the current U-Boot prompt)

I have also looked into using Plymouth as it seems to be a popular option for splash screens, and I did in fact see that Plymouth is initialized already by the current OS release.  I have installed a theme and it doesn't seem to be working (no theme displayed) despite rewriting the initial ramdisk after changing the theme as advised.

Any ideas?

Thanks!
Title: Re: Splash Screens on the A64...U-Boot, Plymouth?
Post by: FalloutST on April 09, 2021, 08:35:36 pm
Membring same problem on gentoo
1) no easy ways
2) shut up u-boot by removing from sorce every output
3) may be needed do the same on systemd
4) https://www.kernel.org/doc/html/latest/fb/fbcon.html

that way https://developer.toradex.com/knowledge-base/splash-screen-linux
still have output of u-boot and some systemd messages
Title: Re: Splash Screens on the A64...U-Boot, Plymouth?
Post by: afancher on April 21, 2021, 03:03:56 am
hmmmm...perhaps a tweak that could be made to the next release Lub might be able to put in the developer's ears about? ;)
Title: Re: Splash Screens on the A64...U-Boot, Plymouth?
Post by: afancher on August 31, 2021, 09:58:27 pm
Any chance of this board ever having splash screen support implemented?